Jump to content
Tom123

ESET Dynamic Threat Defense is not accessible alert in ESMC Console

Recommended Posts

Hey,

 

We're getting an error on every machine with ESET installed of "ESET Dynamic Threat Defense is not activated or licence is invalid"

7b00d05fa060ff098b397499169caa94.png

 

To my knowledge, we do not have a licence for Dynamic Threat Defense, however I cannot find how to disable this from being picked up.

 

9bb967c7dd876cbe3e3db6ca0383cabf.png

 

I am relatively new to the ESET console, so as much help as possible would be appreciated!

 

Cheers,

Tom.

Share this post


Link to post
Share on other sites

If you don't have a license for EDTD, don't enable it. However, we strongly recommend purchasing EDTD which will improve overall protection and detection of new malware, including ransomware. For how many machines your ESET license is? Currently we offer EDTD for users with more than 250 seats but this is gonna change soon and even small offices will be able to purchase the service.

Share this post


Link to post
Share on other sites
Posted (edited)
19 minutes ago, Marcos said:

If you don't have a license for EDTD, don't enable it. However, we strongly recommend purchasing EDTD which will improve overall protection and detection of new malware, including ransomware. For how many machines your ESET license is? Currently we offer EDTD for users with more than 250 seats but this is gonna change soon and even small offices will be able to purchase the service.

Hey, how do i go to "disable" it, as I can't find it anywhere..? 

 

We currently have 230 assigned licences, I will have a chat with the director to see what we actually have and his thoughts, I appreciate the reply.

 

EDIT:

These are the licences on the business account section

73585f935b48b9297877c623f017355a.png

Edited by Tom123

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

you need to enable "Live Grid Feedback System" policy in ESMC (under Cloud-based protection) to make this setting visible.

You can see in ESMC that Dynamic Threat Defense Setting is greyed out until you enable live grid feedback. As long as it is greyed out, it is not visible in client UI.

Chances are, that someone enabled grid feedback, then was able to enable threat defense and disabled grid feedback afterwards. Then threat defense would be in a state that you posted and could not be changed anymore until grid feeback system is enabled again.

Don´t know if this is a bug or a feature 🙂

ad69a12b9cab344adaecef10f8e6d604.png

Edited by MichaelK
Forgot a word.

Share this post


Link to post
Share on other sites

On the screenshot in the original post, the Live Grid Feedback is enabled, and "locked from editing" meaning it is set via policy. What is needed, is to disable that particular setting in the policy assigned to your clients, and then the alert should go away.

You can also disable that particular alert via user interface section of the policy, in the list of the application statuses that should be shown on the client computers, and sent to the ESMC server. That would resolve your issue. 

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, MichaelK said:

Hi,

you need to enable "Live Grid Feedback System" policy in ESMC (under Cloud-based protection) to make this setting visible.

You can see in ESMC that Dynamic Threat Defense Setting is greyed out until you enable live grid feedback. As long as it is greyed out, it is not visible in client UI.

Chances are, that someone enabled grid feedback, then was able to enable threat defense and disabled grid feedback afterwards. Then threat defense would be in a state that you posted and could not be changed anymore until grid feeback system is enabled again.

Don´t know if this is a bug or a feature 🙂

ad69a12b9cab344adaecef10f8e6d604.png

Hey, where am I finding this option? I can goto advanced setup on client machines and it's greyed out, I can also find it on the server and it's enabled and disabling it doesnt show anything else it just greys out the beneath items which we want enabled..

801d82063f8f2b1e2966ae86845fd337.png

I cannot find any policy editor on the security management centre, unless I'm being blind?

15 minutes ago, MichalJ said:

On the screenshot in the original post, the Live Grid Feedback is enabled, and "locked from editing" meaning it is set via policy. What is needed, is to disable that particular setting in the policy assigned to your clients, and then the alert should go away.

You can also disable that particular alert via user interface section of the policy, in the list of the application statuses that should be shown on the client computers, and sent to the ESMC server. That would resolve your issue. 

I am able to disable the option on the server (picture above) however that greys out the below options and surely we want these enabled?? Plus I dont see the Dynamic Threat defense either way..

dd5e718ffcd579c49618c24d965ea25b.png

 

Thanks for all the help so far :)

 

 

EDIT:

I believe I have found it.. but dynamic tread defense is disabled anyway??

478721b8188abc32aea0265985ebc57f.png

Edited by Tom123

Share this post


Link to post
Share on other sites

For EDTD you must have a separate license if it's not already included in the pack you have purchased:

image.png

If you don't have an EDTD license yet, we could provide you with a trial one. Otherwise we recommend enabling the LiveGrid Feedback system and disable EDTD in a policy that is applied on clients.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...