Jump to content

No notification or alert when threat is detected


Go to solution Solved by hqsec,

Recommended Posts

For some time now I don't get an alert in bottom right corner when threat is blocked. I can only see what was blocked if I check Log files. I have alert windows enabled. OTOH I get alerts when database is updated. 

Is there any other setting I should change to get alerts. Attached is my settings printscreen.

 

My specs:

Windows 8.1 update 1 x64

ESET Nod32 AV 7.0.302.26

 

post-3069-0-44689100-1399661982_thumb.jpg

Link to post
Share on other sites

Hi Swex. For some of them I get Nod32's windows asking me what to do (Disconect or no action), similar to PUA detection. For other (that are automatically blocked) I get nothing. There is only an error "Failed - Network error" in Chrome's downloads bar. The detection is recorded in log files though and file is placed in Quarantine.  

Link to post
Share on other sites

I've checked the settings and found workaround for this problem. I've set cleaning level to No cleaning, so AV now asks me with popup when anything is detected. I just don't like things like this happening in background without me knowing it.

Link to post
Share on other sites

Alright, still the notifications shouldn't just stop to popup just like that unless you did change some setting in the product wich made it more automatic. 

 

But if it works as you want now then I guess it's all good.  ;)

Edited by SweX
Link to post
Share on other sites

Thanks SweX. Can you confirm that you get notification if you try to download first test file from site you mentioned? 

Link to post
Share on other sites

Thanks SweX. Can you confirm that you get notification if you try to download first test file from site you mentioned? 

Yes sure :)

 

I can confirm that I do get a detection popup in the bottom right corner of the screen.  The page fails to load, and the detection popup says Connection Terminated. 

Link to post
Share on other sites

Thanks for testing SweX. I've made some more tests on malwaredomain lists and found this out:

1. if malware is blocked by HTTP filter or Real-time file system protection, I get no popup. Event is logged under Detected Threats section. 

2. if website is blocked by internal blacklist, I do get a popup. In this case event is logged under Filtered websites section.

Link to post
Share on other sites
  • ESET Staff

Hi hqsec,

In your first post, you mentioned your Alerts & Notifications settings in advanced setup. I would be curious to know what settings you are using under Message Boxes > Advanced Setup. It's in the same dialog that is shown in your image, but the setting i'm interested is the Minimum verbosity of events to display setting. There is also a setting in there that determines which users see notifications, that might be worth checking on as well.

Link to post
Share on other sites

Hi hqsec,

In your first post, you mentioned your Alerts & Notifications settings in advanced setup. I would be curious to know what settings you are using under Message Boxes > Advanced Setup. It's in the same dialog that is shown in your image, but the setting i'm interested is the Minimum verbosity of events to display setting. There is also a setting in there that determines which users see notifications, that might be worth checking on as well.

FWIW just to compare :).  Mine is "Informative" and "Administrator". 

Link to post
Share on other sites
  • ESET Staff

Yes, those are the default settings. Using those settings I would expect that hqsec would be seeing more notification messages.

Link to post
Share on other sites

Yes I have also default setting enabled - the same as SweX. Even if I change to Diagnostic level I get no notification. I even uninstalled AV, run removal tool from Safe mode and reinstall but it did not help. It looks like it must be something with my system.  :unsure: The strange thing is that I get some notifications, but not all.

Link to post
Share on other sites

Oh right. Well I was going to suggest to use the button wich will turn the product into default state, but if you did a fresh install then that's not needed. ;)

 

Only thing I can think of is if you installed another security app, or changed a setting in an already installed app or in the system wich interferes with this in some way.

 

Uninstalling other security apps, and leaving NOD32 installed using the defaults (for now) to test might give some answers.

 

Or maybe you have found the culprit already?

Link to post
Share on other sites

I didn't find culprit and I'm giving up, as I run out of ideas. I don't use any other real-time.security apps, only some on-demand scanners (HitmanPro, MBAM, Emsisoft EK). 

Link to post
Share on other sites

Have you tried clearing your windows notification cache ?

 

CCleaner has an option to do it in temporary file cleaner.

 

These steps should suffice for manual:

 

(Use at your own risk, editing the registry can cause irrepairable harm, always export or backup reg keys when testing.)

Open the Registry Editor
If you use Windows 7 browse to:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
Delete the data of the following keys in this folder:
 IconStreams
 LastAdvertisement
 PastIconsStream
 PromotedIconCache
 UserStartTime

 

You must restart explorer.exe at the end as its holding cache, or reboot your PC.

 

Then see if your notifications start popping back up. ;)

Edited by Arakasi
Link to post
Share on other sites

That didn't bring back notifications but it did reset tray icons. Since I do get some notifications I don't think that this is culprit. 

Link to post
Share on other sites

I imagine those notifications are built on top of the tray portion of ESET which would be a seperate part of the project files, hence my suggestion.

Sorry it had no effect. :)

Link to post
Share on other sites

 What about the browser, have you tested in more than one browser to see if you get detection popups normally in other browsers? Not that it should matter as the product works with all browser, but since we kinda have runned out of ideas it might be worth a try. If you still use Sandboxie, have you tried without sandboxie just for a test? 

Link to post
Share on other sites

I tested Chrome and Internet Explorer. I can try using Firefox to see if it works there. Will do that when I come home. I have removed Sandboxie right away to rule it out.

Edited by hqsec
Link to post
Share on other sites

OK I've made some more test and found out that this is ESET + Windows 8.1.1. problem. It looks like detected threat notifications are now shown through Windows 8 push notifications. I had those disabled so I couldn't see them. 

One question for developer: could those new push notifications be optional? It would be great if users could choose how they get them. 

It's also interesting that when blacklisted webpage is blocked, I still get normal desktop notification  :unsure:

 

EDIT: don't know if they are "push" notifications - I was talking about new notifications in tiles.

Edited by hqsec
Link to post
Share on other sites
  • Solution

I installed last version 7.0.317.4 and the problem is solved. THANK YOU for quick response and update!  :)

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...