Jump to content

MAMP Pro Apache not work when eset firewall enabled


Recommended Posts

Hello,

I am facing issue with MAMP Pro Apache.

When my eset firewall is on, localhost is not opening. But when I disable the firewall, every thing works good.

I tried adding rule for mamp pro, still not work.

Thanks.

Link to comment
Share on other sites

  • Administrators

In automatic mode non-initiated inbound communication is blocked. Create a rule for inbound communication with the local port 80 and 443 while leaving the remote IP address and port unset.

Link to comment
Share on other sites

Thank you.

Please review the attached screenshot.

I created a rule for port 80 like:

Application: All Application
Action: Allow
Direction: Both
Protocol: TCP & UDP
Ports: Local
Local Port: 80
Destination: Entire Internet

And the local site are working smoothly.

Could you please suggest me if I need to each ports separately like for 443, and 4200 for angular, 8080 for anther service etc.

Thanks.

Screen Shot 2020-05-30 at 20.39.43.png

Link to comment
Share on other sites

  • Most Valued Members
On 5/31/2020 at 3:02 PM, prayas said:

Comma separated ports are not accepted by eset.

Like I tried 80,443,3306 but it does not accepted.

Make multiple rules with seperate port each for the same application so you will have them multiple

seperating ports by comma should work as far as I know.

Will that work?

Edited by Nightowl
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...