Jump to content

Recommended Posts

Hello,

I use MS Teams for videoconferences, phone call ... Since few weeks, I have issues. Indeed, I am not able to join conference call/online meeting if ESET is installed. The call start, people can listen to me and then after 10-15 seconds, Teams close the call saying "Sorry, we're unable to connect you".

If I close ESET, issue still there. If I uninstall ESET, issues disappear.

How can I solve this issue ?

Kind regards,

Link to post
Share on other sites
  • Administrators

Please make sure that you don't have other than 80 or 8080 ports listed among HTTP ports (in particular, 443 must not be there).

If that's not the case, please collect logs as per https://support.eset.com/en/kb3404-use-eset-logcollector-on-macos-and-send-the-logs-to-eset-technical-support and raise a support ticket with your local ESET distributor.

Link to post
Share on other sites

Hello,

I have the same problem, several employees complain, they can no longer join team meetings (same problem mentioned above). 
At the beginning I thought it was from Microsoft because the simple calls work very well and on the same mac with the antivirus, the meetings work very well with the web version of Microsoft Teams.
As a result, I do not know if it is ESET (ESET Endpoint Security )the problem but in doubt and having seen the question, if you find a solution I'm interested.

Ports 80 and 443 are well open on my side.

in HTTP protocol checking i have 80,8080,3128

Mac Os version : 10.15.4
Version Teams : 1.3.00.8663
Version ESET Endpoint Security: 6.8.400.0

Thank you for your help,

Edited by seb38300
Link to post
Share on other sites

Same to me since a couple of days.

1:1 calls work fine. Meetings and Conferences not.

By deactivating the ESET firewall, everything works normal.

macOS 10.15.4 with Microsoft Teams 1.3.00.9271 an ESET Endpoint Security 6.8.400.0

Link to post
Share on other sites
  • Administrators

Please collect logs as per the KB above and raise a support ticket with your local ESET support.

Link to post
Share on other sites
Posted (edited)

According to this: https://docs.microsoft.com/en-gb/office365/enterprise/urls-and-ip-address-ranges#skype-for-business-online-and-microsoft-teams , Teams is using a whole lot of other ports beside 80, 443, and 3128 depending on how its interfacing is configured. Namely:

11 Optimize Required Yes 13.107.64.0/18, 52.112.0.0/14, 52.120.0.0/14 UDP: 3478, 3479, 3480, 3481

Edited by itman
Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)

Finally found a topic talking about this... Since last week with that same problem. Could never imagine that could be ESET, deactivated firewall and it worked. Any news about this issue?

 

Edit: Maybe it has a link to the Mac OS version... The issue is happening to me on Catalina, but i have another Mac (2011 can't remember mac os version now) with cyber security pro too and everything works fine.

 

Edit2: Forget about it... maybe it wasn't updated yet... Same problem in my mac 2011 Sierra

Edited by wyll.cavalcante
Mac OS Version
Link to post
Share on other sites
Posted (edited)

As a matter of interest, internally ESET is not having any problems with either ESET firewall or Microsoft teams so there must exist a setup which will happily work.

 

Edited by Hpoonis
Link to post
Share on other sites
On 5/7/2020 at 11:49 AM, Marcos said:

Does creating a permissive bi-directional firewall rule for the following app help?


 /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app

 

This one gave me a hint... i've searched how to add that "helper" and found this:

https://support.eset.com/en/kb3301-create-a-firewall-exclusion-using-interactive-mode-in-eset-cyber-security-pro

Changed to interactive mode and ESET identify the network interactions... Just a little boring the permission/deny dialog boxes but if you trust the app/connection mark the check to remember and create rule.

 

Teams working fine now.

 

Screen Shot 2020-05-18 at 11.23.30.png

Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)

Seems that creating the following rule is sufficient: 

Name: Allow Teams Helper
App: /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app
Action: Allow

Direction: In
Protocol: TCP & UDP
Ports: Remote
Remote Port: All
Destination: Entire internet

Edited by Mitchell
Link to post
Share on other sites
Posted (edited)

I haven't been able to reproduce the issue on the latest version of ESET Endpoint for mac OS (6.9.60), So upgrading seems to be the easiest fix. 

 

Edit: I'm not sure if there is a newer version of ESET Cyber Security though. 

Edited by Mitchell
Link to post
Share on other sites
  • 4 weeks later...
On 5/27/2020 at 10:11 AM, Mitchell said:

Seems that creating the following rule is sufficient: 

Name: Allow Teams Helper
App: /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app
Action: Allow

Direction: In
Protocol: TCP & UDP
Ports: Remote
Remote Port: All
Destination: Entire internet

Thanks. That did it perfectly. Mac OS 10.13.6 and apparently started causing problems with the end user updated to the latest version of teams a few weeks ago. Currently has teams version: 1.3.00.15561 and it says it updated on 25th June 2020.

Link to post
Share on other sites
  • 3 weeks later...
On 5/7/2020 at 9:49 PM, Marcos said:

Does creating a permissive bi-directional firewall rule for the following app help?


 /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app

 

Why must create rule? I think ESET must  know that application is MS Teams and  allow connection. This problem cause everyone not happy. My computer has this problem today.

Link to post
Share on other sites
  • Administrators

In automatic mode all non-initiated communication is blocked. If a server initiates a communication, you must create a permissive rule for it.

Link to post
Share on other sites
33 minutes ago, Marcos said:

In automatic mode all non-initiated communication is blocked. If a server initiates a communication, you must create a permissive rule for it.

Dear Marcos, How to allow all communication after i will block when i have demand?

And why MS Teams or Skype on Windows are not block as on MAC? 

 

I think on automatic mode, popular application are should allow.

Link to post
Share on other sites
  • Administrators

We recommend switching to interactive mode, run Teams, create the appropriate rules and then switch back to automatic mode.

Mac and Windows are different operating system and so are ESET products for Windows and Mac. It's not possible to compare them 1:1. Moreover, Teams might work and communicate differently on different OS.

Link to post
Share on other sites
19 hours ago, Marcos said:

We recommend switching to interactive mode, run Teams, create the appropriate rules and then switch back to automatic mode.

Mac and Windows are different operating system and so are ESET products for Windows and Mac. It's not possible to compare them 1:1. Moreover, Teams might work and communicate differently on different OS.

I see, but if ESET know this issue so why not resolve to automatic allow believe application?

Link to post
Share on other sites
  • 1 month later...
On 7/22/2020 at 5:40 AM, Viet_Hoang said:

I see, but if ESET know this issue so why not resolve to automatic allow believe application?

@Marcos, this Teams helper application is signed by Microsoft and was not an issue in the past.  

End user will need instructions of what to do.  Not ideal, can't you have know good list of signed applications that are authorized?  

still an issue with Eset v6.9.60.

 

Link to post
Share on other sites
  • Administrators

The firewall logic has not changed over years. We assume that Teams has been updated and now works in the way that a connection is initialized by the server. In automatic mode, all outbound communication is allowed and all non-initiated inbound communication blocked, hence a rule for Teams may need to be created. It is beyond us to have a list of all 3rd party applications where the communication is initiated from outside and maintain the rules for them.

 

Link to post
Share on other sites
  • 2 weeks later...
On 9/10/2020 at 2:03 PM, Marcos said:

The firewall logic has not changed over years. We assume that Teams has been updated and now works in the way that a connection is initialized by the server. In automatic mode, all outbound communication is allowed and all non-initiated inbound communication blocked, hence a rule for Teams may need to be created. It is beyond us to have a list of all 3rd party applications where the communication is initiated from outside and maintain the rules for them.

 

I appreciate that it is not possible to track all third party apps but given the popularity or Office 365 and the current need for Teams is there a way to request that the engineering team can track this one?

I am having the same issue here, I have tried setting rules for:

 /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app

TCP&UDP, all ports, all IPs, both directions

/Applications/Microsoft Teams.app

TCP&UDP, all ports, all IPs, both directions

But still Teams will not work properly, as soon as I disable EES firewall it works perfectly. I switched to interactive mode and allowed each connection but they seem to be never ending so the call fails before I can allow them all, there is also no option to remember the action as a rule like on Windows, just "apply action" or "temporarily remember". Is this right? 

Thanks

Link to post
Share on other sites
  • ESET Staff
29 minutes ago, PuterCare said:

I appreciate that it is not possible to track all third party apps but given the popularity or Office 365 and the current need for Teams is there a way to request that the engineering team can track this one?

I am having the same issue here, I have tried setting rules for:

 /Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app

TCP&UDP, all ports, all IPs, both directions

/Applications/Microsoft Teams.app

TCP&UDP, all ports, all IPs, both directions

But still Teams will not work properly, as soon as I disable EES firewall it works perfectly. I switched to interactive mode and allowed each connection but they seem to be never ending so the call fails before I can allow them all, there is also no option to remember the action as a rule like on Windows, just "apply action" or "temporarily remember". Is this right? 

Thanks

Hi @PuterCare,

To help us investigate this issue please can you make sure you are running the latest version of ESET Endpoint Security / Antivirus for Mac or ESET Cyber Security / Cyber Security Pro.

ESET Endpoint Security Mac - https://www.eset.com/int/business/endpoint-security-mac/download/
ESET Cyber Security Pro - https://www.eset.com/int/home/cyber-security-pro/download/

Once you are running the latest version (if not already) please can you capture logs as per the instructions in the following KB - https://support.eset.com/kb3404

Please submit these logs to your Local ESET Office and they will be able to advise on next steps and investigate the issue for you.

Regards,

Link to post
Share on other sites
2 hours ago, TomPark said:

Hi @PuterCare,

To help us investigate this issue please can you make sure you are running the latest version of ESET Endpoint Security / Antivirus for Mac or ESET Cyber Security / Cyber Security Pro.

ESET Endpoint Security Mac - https://www.eset.com/int/business/endpoint-security-mac/download/
ESET Cyber Security Pro - https://www.eset.com/int/home/cyber-security-pro/download/

Once you are running the latest version (if not already) please can you capture logs as per the instructions in the following KB - https://support.eset.com/kb3404

Please submit these logs to your Local ESET Office and they will be able to advise on next steps and investigate the issue for you.

Regards,

Hi Tom, I had updated Eset ES on the systems before trying any of the above so I will try to capture that info now and send to my Eset rep. Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...