Jump to content
Kirbo

ESET not recognized by Windows Security and Maintenance after 13.1.16 update

Recommended Posts

I updated to the latest build of ESET around an hour ago, and checked Windows Security and Maintenance to make sure everything was working properly. On the Security and Maintenance window, it shows ESET's antivirus and firewall as being off, and selecting the option to turn them on does nothing. The splash page for ESET appears normally on start-up and the ESET application itself says that both the antivirus and firewall are okay. It seems that the ESET app is functioning without any issues, but I am a bit concerned that Windows seems to think otherwise.

Share this post


Link to post
Share on other sites

What OS do you use? On Windows 10 there is no "Security and maintenance" window and EIS 13.1.16 is correctly registered in WSC:

image.png

Share this post


Link to post
Share on other sites

I am using Windows 10 build 1909. The included image shows the Start menu selection for the Security and Maintenance window I am referring to.

SaM.png

Share this post


Link to post
Share on other sites
Posted (edited)

Hello @Kirbo ,

Could you also post a screenshot of the issue?

Could you also check ESET event log and check if there are some messages about failures with Windows Security Center?

Thanks,

Jozef

 

Edited by JozefG

Share this post


Link to post
Share on other sites

The event log doesn't show any conflicts with WSC. The WSC shows that it recognizes that ESET is on the computer, but does not recognize it as being 'on'. Is there any way for me to rollback to v13.0 for now?

Share this post


Link to post
Share on other sites
23 minutes ago, Kirbo said:

The WSC shows that it recognizes that ESET is on the computer, but does not recognize it as being 'on'.

Any screen shot of this?

Share this post


Link to post
Share on other sites
Posted (edited)

In WSC Threat & Protection section, the following screen shot would show that Eset Security is turned on:

311890268_WD_VT.thumb.png.ab5d8b7e6414d15990483e824804e1fc.png

Next mouse click on "Manage providers." It should show the following noting that Eset Security is the active real-time AV solution and Eset Firewall is the active firewall solution:

WD_Security_Providers.thumb.png.4ffc0a889a4b9618fb1a2e8d46c32c5c.png

Edited by itman

Share this post


Link to post
Share on other sites

ESET is recognized by WSC but is not recognized as being 'on' and trying to turn it on from the WSC does nothing.

DnBCZ2w.jpg

Share this post


Link to post
Share on other sites
3 hours ago, Kirbo said:

On the Security and Maintenance window, it shows ESET's antivirus and firewall as being off, and selecting the option to turn them on does nothing.

As far as what S & M in Win 10 1909 should be displaying, it should be deferring to Windows Security Center per the below screen shot:

1515481549_Win_SM.png.93b2dfab022287d56dc6a8466f5ae0f8.png

 

Share this post


Link to post
Share on other sites
Posted (edited)

@Kirbo Can you please take a screenshot of modules?

Make sure you have this one present in the list

image.png

Edited by JozefG

Share this post


Link to post
Share on other sites

Looking at the modules list, it appears that the one you listed isn't present. I haven't connected the computer in question to the internet ever since the update as I was unsure if everything was working properly. Is it safe to assume then that this missing module will be downloaded if I connect to the internet and update ESET?

Share this post


Link to post
Share on other sites

The module must be present as long as you have v13 installed. Please provide logs collected with ESET Log Collector.

Share this post


Link to post
Share on other sites

Mouse click on Installed Components. Security Center integration module should be the last one listed:

Eset_Installed.thumb.png.33dbbfa775d0099b8257e1da419ad391.png

Share this post


Link to post
Share on other sites

As I stated earlier, the Security Center integration module is not listed.OrIdBeK.thumb.jpg.4915e41a8a28ad9040db89da3ecae812.jpg

Share this post


Link to post
Share on other sites
9 hours ago, Kirbo said:

As I stated earlier, the Security Center integration module is not listed.OrIdBeK.thumb.jpg.4915e41a8a28ad9040db89da3ecae812.jpg

In that case please run update and let the module to be downloaded.

As name of this module suggests it is responsible with integration within Windows Security Center.

Share this post


Link to post
Share on other sites

Thank you. I ran an update and now everything is working perfectly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...