Jump to content
Gregecslo

EFS network performance issues

Recommended Posts

Hi everyone!

We have deployed 10G networking in our datacenters. We also have Windows Server 2019 servers (latest CU) and EFS 7.1.12006 deployed on them. When we did network tests, we were really dissapointed to see 2GB/s only troughput.

So I did test with iperf3 between Linux servers, results were OK, 10GB/s as expected.

So I did another look at my Windows servers, removed EFS and got expected 9GB/s.

We also contacted local support without success. With them we tried to rename driver ekrnEpfw.dll but results were the same.

We tried with Windows defender and have no such issue there.

What can we do to troubleshoot and resolve this one?

Attached iperf3 test results.

 

Thanks!

eset_iperf_network.txt

Share this post


Link to post
Share on other sites

I just opened support case with all logs attached...

Share this post


Link to post
Share on other sites

Do you run applications from a network share? Especially large ones?

Share this post


Link to post
Share on other sites
Posted (edited)

No.

Fileshare copy file from one server to another gives me 2Gbit/s.

See iperf logs. Iperf does not use any kind of network share and port 5201 is used that has nothing to do with fileshare.

No matter which port I use result is alwyas the same.

If I remove eset and reboot I get 9Gbit/s instantly.

Edited by Gregecslo

Share this post


Link to post
Share on other sites

Hello.

I still haven`t got any reply from local support and not from here. Is it not possible for you to replicate this one?

I uninstalled EFS from 4 servers where I need 10GB network speed and I`m using Defender now.

What`s the point of having EFS licences if I will end up using Defender on 100 servers I have?

 

Regrads,

G

Share this post


Link to post
Share on other sites
33 minutes ago, Gregecslo said:

Hello.

I still haven`t got any reply from local support and not from here. Is it not possible for you to replicate this one?

I uninstalled EFS from 4 servers where I need 10GB network speed and I`m using Defender now.

What`s the point of having EFS licences if I will end up using Defender on 100 servers I have?

 

Regrads,

G

It sounds to me some kind of a bug that when EFS is trying to read what you trying to get from the Share , it's slowing down the operation

an ESET staff should be able to help you , maybe if you reply to the same support email , that might bump the ticket to the local support again.

If you can get to the Phone Support it's faster than the email one and the support guy cannot run away from you that way :D

Share this post


Link to post
Share on other sites
Posted (edited)

Well,  got reply from local support.

They said (ESET said), that problem is "within OS of the server".  ???

So...

Server 2008 - 2019 have apparently the same "OS problem" according to my tests :)

Without ESET speed jumps from 2 Gbit/s to 9.5 Gbit/s, so WHO has the problem here?

I`m truly disappointed on what kind of answers we are getting.

Edited by Gregecslo

Share this post


Link to post
Share on other sites

We have contacted Microsoft with details about the issue and now anticipating a response. We'll keep you posted.

Share this post


Link to post
Share on other sites

Are there any updates about the topic. I have the same Issue with EFS 7.1.12010 and Server 2019.

Share this post


Link to post
Share on other sites
20 minutes ago, MichaelS said:

Are there any updates about the topic. I have the same Issue with EFS 7.1.12010 and Server 2019.

Does temporarily pausing real-time protection or installing EFSW without network protection make a difference? I'd recommend opening a support ticket with your local ESET distributor for troubleshooting.

image.png

Share this post


Link to post
Share on other sites

Pausing the real-time Protection make no difference. I have disable the Network Protection in the Eset Webconsole for the Server.

I would test it without Installing Network Protection. Can i create a Task for install EFS without Network Protection?

Share this post


Link to post
Share on other sites
On 4/26/2020 at 8:11 PM, Marcos said:

Does temporarily pausing real-time protection or installing EFSW without network protection make a difference? I'd recommend opening a support ticket with your local ESET distributor for troubleshooting.

image.png

Did that as well, same result.

 

What happened with:

On 4/6/2020 at 10:00 PM, Marcos said:

We have contacted Microsoft with details about the issue and now anticipating a response. We'll keep you posted.

?

 

I have case opened with local ESET support.

Share this post


Link to post
Share on other sites

The issue with Windows that we contacted MS about was related to network if I remember correctly. Please provide ELC logs from time when EFSW is installed without network protection to make sure that no network-related drivers are installed.

Share this post


Link to post
Share on other sites

Is it possible to do this from command line at install time?

Share this post


Link to post
Share on other sites

Ah OK. I got it wrong. On server was with network prot other not.

Now I did manual install, and it seems OK, results are almost as without AV installed.

 

Can this be solved in further product version?

Thanks!

Share this post


Link to post
Share on other sites

On a serve where the issue is manifesting, could you please try switching updates to the pre-release update channel in the advanced update setup so that the Firewall module 1400.3 is downloaded? Afterwards reboot the server and check if the issue is gone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...