Jump to content

Cannot install updates after upgrading ESMC


FrankNicklin
 Share

Recommended Posts

I have just upgraded a server (2nd one) to ESMC 7.1 from 6.X and started to roll out upgrades to clients.

Every client is failing to install with the same error which appears to be related to installing the services. On the server, the upgrade process removed the old 6.5 File Server protection but then failed to install the update so now the server is not protected. A fresh install on a new machine worked fine, but I cannot upgrade existing clients.

I have created a package and tried installing it manually but the result is the same. I have scanned the server with the Specialized Scanner as suggested and the server is clean. The suggestion of using the Uninstall tool is way to convoluted to use on a server, i.e. safe mode, backing up settings and the risk of loosing network drivers is too big an issue to risk on a production server and is a server I cannot take down easily anyway because of usage requirements.

This is proving to be a real problem as my clients PC's are having issues with the Phishing modules and out of date software hence the reason I upgraded.

Any suggestions as to why the clients will not upgrade or install.

Screenshot 2020-02-27 at 20.39.00.png

Link to comment
Share on other sites

  • Administrators

Please install Endpoint manually on one machine and generate an install log as per the instructions https://support.eset.com/en/kb406-how-do-i-generate-an-installation-error-log-for-windows-eset-products. When done, provide the install log as well as logs collected with ESET Log Collector for perusal.

Link to comment
Share on other sites

  • ESET Staff

Please provide us log files available in directory %temp%/eset , i.e. in temporary directory of user that executed installer. It will contain full installer logs for each installed component so that we can check what is going on.

Link to comment
Share on other sites

The install is an exe package file generated from EMSC so creating the install.log will not work. Also there is not an C:\WINDOWS\INF\setupapi.app.log or C:\WINDOWS\INF\setupapi.dev.log dated today after another attempt at installing.

I have attached the eset logs from %temp%/eset. 

The install is from a Server 2012R2 machine.

I also have a VM running Server 2012R2 on this machine and that upgraded OK.

 

 

liveinstaller_20200228105450_eraa.zip

Edited by FrankNicklin
Link to comment
Share on other sites

  • Administrators

Error 1923. Service 'ESET Service' (ekrn) could not be installed. Verify that you have sufficient privileges to install system services.

Please provide a Procmon log from installation as per https://support.eset.com/en/kb6308-using-process-monitor-to-create-log-files.

Is the user under which installation is run able to write to HKLM\System\CurrentControlSet\services ?

Link to comment
Share on other sites

I have run the install from login as domain administrator. I have also right clicked and run as administrator. Both fail with the same issue. I had a previous version installed prior to this V6.5 and that installed and ran without issue. The upgrade process removed this version prior to trying to install the new version which is when I ran into this issue.

I have attached the log file here. I was going to raise a ticket referencing this discussion but am limited to 8mb uploads from the ticket system which is a bit limiting.

I will raise a ticket and link the details back to this discussion.

 

 

Logfile.zip

Edited by FrankNicklin
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...