Jump to content
morezen

Renew button goes to Error page on Australian website

Recommended Posts

Hello

I hope this is the correct place to post this query. I have sent messages to ESET support International and no one has replied yet.

I have been a customer of ESET for more than 10 years and am extremely computer literate. Each year I have successfully renewed ESET using the Australian web portal, however at the moment all links to RENEW my ESET license via the Australian website DO NOT work right now. The link to renew inside the ESET GUI is also not working.

Steps to replicate problem.
Please note my I.P. is based in Australia, as I believe this may be part of the problem.

1. Go to this link:
https://www.eset.com/au/support/existing-customers/

2. Press Renew button

3. A re-direct then goes to this link:
https://go.eset.com/renew/?_ga=2.268813942.684404668.1581554792-672009164.1581554792

4. Then it re-directs again and finally ends up here:
https://www.eset.com/store/
On this page it reports a re-direct error and suggests to "Try clearing your cookies".
I then clear my cookies, but this does not change a thing.

5. I have tried Google Chrome, Firefox, IE, Edge and Opera - all web browsers suffer from the same error.

I managed to send a message to the Australian Support email address and they asked me to phone them to process my order.
When I explained to them there was a problem with the AU website, they said "yeah we know about the problem, but don't know how to fix it" !!!
When I asked if they had reported this to ESET headquarters, they had no interest in pursuing the matter any further.
I can't believe they don't care about the website not working !?

Does ESET International realize there is a problem with the Australian website ?
My guess is that they must be loosing some customers because of this problem.

Can someone please investigate this problem OR tell me who I can send a message to, to get it fixed ?

I have uploaded some screen shots to show the problem.

Regards
Derek
 

 

ESET-renew-redirect-too-many-times.png

ESET-renew-your-license-1.png

Share this post


Link to post
Share on other sites

Hi,

I have the exact same problem. Not sure if it will help much but I found that if I used my phones mobile internet, then I was able to access the renew page, even from the link in the Eset app. I was planning on upgrading from nod32 to internet security, but it wont allow me to pay for either the internet security or smart security premium with paypal, so I am going to stick with the basics until this problem is resolved.

Share this post


Link to post
Share on other sites

Thanks @Greg96 - your suggestion worked.

There is something really weird happening here ?

I just tried your suggestion using Google Chrome on my phone with my Home Wi-Fi connected to the phone. The first time I tried it went to the same error page.

Next I cleared the Chrome cache.

I then turned off the Wi-Fi connection for the phone, so it was only using my phones Optus Mobile Network connection.
This time it worked !!!
It ended up on https://au.store.eset.com/renewal/check

Cheers :)

Edited by morezen

Share this post


Link to post
Share on other sites

Thanks @Aryeh Goretsky for reporting this issue.

It seems the problem may have something to do with the location it thinks my Internet Connection is coming from ?
When I used my phone and forced it to use the Cell Tower connection (instead of home Internet connection via Broadband Network), it worked OK this time.

Cheers :)

 

Edited by morezen

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...