Jump to content

ESET Enterprise Inspector: "Unknown Protocol" / "Certificate verify failed"


Cp3p0
 Share

Recommended Posts

Hi All,

I'm turning to the forums for help.

I'm experiencing trouble getting my EEI Agents to report back to the EEI Server.
After EEI Agent installation I receive the warning messages from within the ESMC:
"Missing or invalid SSL certificate or certificate authority" & "Can't connect to Enterprise Inspector Server"

From the trace log found under "C:\ProgramData\ESET\EnterpriseInspector\Agent\logs" on the machine I can see errors like:
"Error while sending request to server at "xxxx.local:8093". unknown protocol"
"Error while sending request to server at "xxxx.local:8093". certificate verify failed"

Please help! I've been scratching my head but cannot see where I went wrong with the configuration?

I will outline the steps I've taken below:

1) Install the EEI Agent using the following Client Task from the ESMC console:1058442736_Affecteddevice3.png.de0aa9aeab9261a32f9b8b02cac66434.png

2) Apply a new ESET Enterprise Inspector Agent Policy where I define the only CA found in my ESMC under "Certificate Authorities". Please note there are no other Enterprise Inspector Policies applied:
1531202434_Affecteddevice4.thumb.png.cc620d89c9886c8b728bb396479fcbcd.png

1686622301_Affecteddevice2.png.93ba2ae3ce8b9cd5cf4952b564454844.png1527770339_Affecteddevice5.png.e62310742c7da676bcac0ab80aaa04d6.png
3) After a replication or two these are the errors visible from the ESMC:897558028_Affecteddevice1.png.fe429de57e7602047363d9cae58d47c9.png


4) Trace log from the EEI Agent Machine:2036712663_Affecteddevice6.thumb.png.335c8433c5b4b4658e0f127d413dc51e.png

Re-installing the Agent both via Client task/Manual Repair does not resolve the issue :(.

Any advice would truly be appreciated!

Thank you.

Link to comment
Share on other sites

  • Cp3p0 changed the title to ESET Enterprise Inspector: "Unknown Protocol" / "Certificate verify failed"
  • ESET Moderators

Hello @Cp3p0,

a colleague wit EEI expertise spoke to me regarding it, so please check the EEI server cert in the ESMC - in the host field you need to have host name and/or IP address of the server.

So you probably will have to create the new cert from, of course using the same CA and reinstall the EEI server with it, please let us know if that helped.

Peter

Link to comment
Share on other sites

  • ESET Staff

Hi,

please make sure that the proxy server has TLS enabled. And as my colleague mentioned before, better to prepare new EEI Server certificate. It can be easily done during the Installation/Repair process https://help.eset.com/eei/1.3/en-US/gui_server_installation.html

Link to comment
Share on other sites

Thank you guys for the response!

With your help I figured out what the issue was. 

The EI Server certificate only contained the EI Server host name.
However, my EI Agents used the my server Alias as the "Connect to Server" address.

Note to self, if you're going to use the alias for connecting your Agents, make sure it's also mentioned on the EI Server Certificate.
(Not just the server hostname.... Duh)

Edited by Cp3p0
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...