Jump to content

Alerts and Notifications via Email


Recommended Posts

We use Google apps exclusively in our business - we have no local server.

 

So I'm trying to figure out a way for ESET's Smart Security to send using smtp.gmail.com:465.

 

Questions:

  1. Is this even possible?
  2. How do I test to make sure that the machines are configured correctly?  There appears to be no "test" button to verify the configuration.
  3. What logs can I look at to see what errors or successes Smart Security may be having while trying to communicate with an SMTP server?
Link to comment
Share on other sites

  • Administrators

1, sending via SMTPS is not supported (yet)

2, in a business environment, you should use ESET Endpoint products instead of consumer products (ESET NOD32 Antivirus and ESET Smart Security)

3, the SMTP notification feature was removed from consumer versions but was re-added in v7. No other changes were made to this feature as it's primarily intended for business clients.

Link to comment
Share on other sites

Sorry, I think my initial sentence was a bit vague.  We use Google Apps  in our organization, my goal in mentioning that was so that it wouldn't be assumed that we have the ability to create a custom port on our SMTP servers.  I didn't do a good job here.

 

The Smart Security software we install only goes on residential machines.

 

To your answer, if I'm understanding you correctly, you're basically saying that the email feature, while there, doesn't really work unless you're in an enterprise that's running it's own mail servers?

 

If my assessment is accurate, is there a way to configure the Endpoint solution so that mobile users can use alternate SMTP ports?

Link to comment
Share on other sites

  • Administrators

To my best knowledge, you can add the port after the address of the SMTP server. What doesn't work is secured SMTP which is utilized by Google as well. Non-secure SMTP utilizes port 25 by default.

Link to comment
Share on other sites

  • Administrators

I was really hoping that this solution would work better than it once did. 

 

Nothing has changed in terms of functionality of the SMTP notification feature. If it worked in the past, it must work now, too. However, notifications over SMTPS have never been supported in any of ESET's products and versions. Of course, this may be subject to change in future versions.

Link to comment
Share on other sites

  • 3 weeks later...

Trouble is, it didn't work very well then, either.  It was fine if you had an inner office SMTP server, but for employees with laptops who could be on any number of ISPs, if you didn't have the ability to change that port number, the email feature didn't work as virtually all ISPs block port 25.  And with the cloud gaining even more popularity, the need to change the port and use SMTPS is even more important, for both home and enterprise clients - especially for enterprise clients that are regulated by HIPAA and HITECH.

Link to comment
Share on other sites

  • 6 months later...

Hi,

 

Yes, the port can be added.

But the problem is that the most e-mail provider nowadays not only use another SMTP port than 25, they also require to configure SSL / TLS connection settings together with the changed Port.

 

Google Mail for example requires port 465 and to have TLS/SSL enabled.

 

I tried it but got it not working, to set up these settings in ESET to be used for alerts notification. :-(

Link to comment
Share on other sites

If you are making a connection designated as a secure port by the server, the handshake will have cert and key tradeoffs regardless. You wont connect to the server without the key.

 

Have a look at this Google support page and to be hasteful i have added some answers found therein.

https://support.google.com/a/answer/176600?hl=en

 

server: aspmx.l.google.com ( Although you mentioned the port 25 being blocked by ISP's - Solution: USE A VPN )

- Port 25 - TLS not required

server: smtp-relay.gmail.com ( - Also have to use port 25 )

-Port 25, 465, or 587
SSL/TLS optional.

 

 

If your device or application does not support SSL - connect to aspmx.l.google.com on port 25.

You must configure an SPF record for your domain with the IP address of the device or application to ensure that recipients do not reject mail sent from it. You must also add this IP address to the Email Whitelist box in your Google Admin console. For example, if your sending device sends from 123.45.67.89, add that address to your SPF record without removing the Google Apps mail servers from the record: v=spf1 ip4:123.45.67.89 include:_spf.google.com ~all

 

Also the port 25 issue, but there are ways around your ISP block.

 

Good luck !

Link to comment
Share on other sites

  • 1 month later...
Arakasi,

 

Thanks for that information.  Naturally, we'd prefer that everything we send over the net is encrypted as encryption is a basic fundamental that I'm surprised that ESET hasn't integrated into their software, yet.  But this might provide us with a good alternative for those situations where we really think we need this kind of notification.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...