Jump to content

Archived

This topic is now archived and is closed to further replies.

PuterCare

Office 365 SMTP not working in ESMC 7.1 (or 7.0)

Recommended Posts

I have been having trouble setting up SMTP using an Office 365 exchange mailbox. I have searched this forum and found numerous threads where people had issues and checked working configs against my own and just can't work out what is wrong. 

My current config:

image.png.0b75f9c8b36f5adc22b38e9dad3f5ff3.png

I have MFA enabled and have generated an app password, the same account works fine on other devices where I set up SMTP. I have tried using outlook.office365.com as the server too, also tried port 25, TLS and a few auth types but nothing works. 

Any ideas where I am going wrong? I know the login credentials are valid so it is as if it's the auth type or perhaps my VA is somehow using an old TLS standard which Microsoft have now blocked? I have no outbound firewall.

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

Could this thread be your solution as well?

 

Share this post


Link to post
Share on other sites

Thanks for the reply but I have already generated a new app password and tried an existing app password that I use for other reporting services. That was the thread I used to get the Auth type and was the first time I have seen outlook.office365.com used as the server so tried that too but no use.

Share this post


Link to post
Share on other sites

Any more ideas? When I get time I will try migrating my DB to a fresh VA but not likely to have time for a while yet,

Share this post


Link to post
Share on other sites

Is anyone able to confirm the TLS version used for notifications? I'm running out of ideas so wondered if it is using TLS 1.0/1.1?

Share this post


Link to post
Share on other sites

Finally got this working, it looks like the issue was Microsoft blocking the SMTP AUTH as it was deemed "Risky". I had to log into Azure portal and manually mark it as safe, then after about an hour it started to work with Automatic authentication selected. 

Share this post


Link to post
Share on other sites

@PuterCare: Hi, where exactly did you make the settings in the portal? Thanks

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...