Jump to content

Recommended Posts

I tried accessing the internet and all https based sites got an invalid certificate warning. (MOZILLA_PKIX_ERROR_NOT_YET_VALID_ISSUER_CERTIFICATE in firefox or DLG_FLAGS_SEC_CERT_DATE_INVALID in edge). Looking at the certificate, I found the following information.

  • Common Name: www.google.com
  • Issuer name: ESET SSL Filter CA.
  • Valid: 12/20/2019, 2:13:44 PM - 3/13/2020, 2:13:44 PM (Central European Standard Time) [this includes the current date/time]
  • Certificate Authority: No [Looks suspicious to me]

About system time: My system clock is at 20 jan 2020, which is correct and in the time range. However, looking at the time of download of ESET, I noticed that it showed the date of tomorrow, for some weird reason. Still, this time was in the provided time range, so it shouldn't matter, right? (If it does, the problem should magically fix itself in the morning).

About websites:  There were a few websites I tried, including google and eset, just in case google mis-configured their certificates. Since that did not work, I disabled my HTTPS web scanning for now. I will re-check tomorrow, if the installation date had some influence on the https webshield. For now, I keep it disabled. Not the ideal situation but it resolves the issue, for now. Is there anything else I can do to fix it or to help provide extra information in order to fix the issue?

Given this issue claimed potential other software and because my application is a reasonably fresh windows installation, I'll give an exhaustive list of applications installed on my computer:

  • Windows 10 home with latest updates
  • Keepass 2.44
  • Firefox (No plugins or addons)
  • ESET NOD32 antivirus
  • Visual studio 2019 (restart pending)
  • IntelliJ IDEA
  • Steam (No games)

I literally installed no other software on my machine. There are programs on my D drive (still existing after a re-installation), but as far as windows is concerned, they are not installed.

I have created a log archive and attached it. It can be that I accidentally cleared logs when I tried to convert them to text format.

eav_logs.zip

Share this post


Link to post
Share on other sites

Please try the following:
- disable SSL filtering in the advanced setup and click OK
- restart Windows
- without launching any application, re-enable SSL filtering
- check if the issue is resolved.

Share this post


Link to post
Share on other sites

Glad to hear it's resolved. If you would like to get protection from network attacks (typically bruteforce RDP attacks used by attackers to get into machines to run ransomware and then extort money from victims) and to get additional botnet detection to recognize communication of unknown bots within botnets as well as to get protected against exploitation of unpatched vulnerabilities in network protocols, we recommend upgrading to ESET Internet Security (EIS) or ESET Smart Security Premium (ESSP).

Besides these additional protection features, EIS also provides Anti-Theft and Antispam and ESSP also Disk encryption and Password manager.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...