Jump to content
hoodwink

Tags crashing ESMC service

Recommended Posts

After adding my first tag to two computers, ESMC now crashes (EraServerSvc changes to a stopped state) whenever I navigate to any page which involves tags (Computers, Detections, Users, etc.). When I attempt to open any of these pages, an error message is displayed "Failed to load all tags" if I click the OK button a new error appears reading "Failed to load data, report resolving failed: null". At which point the EraServerSvc changes to a stopped state.

Does anyone know how to fix this?

ESET Security Management Center (Server), Version 7.1 (7.1.717.0)
ESET Security Management Center (Web Console), Version 7.1 (7.1.393.0)

ESMC installed on Windows Server 2012R2 and database running on Windows Server 2012R2 and MSSQL 2017 (14.0.328.1)

 

Share this post


Link to post
Share on other sites

Is the ESMC running on a system powered by an older CPU without SSE4 instructions? If so, then it's a known issue. There's a workaround by running a specific query on the database that will delete all tags.

Share this post


Link to post
Share on other sites

Hello, I have the same problem.

ESET Security Management Center (Server), Version 7.1 (7.1.717.0)
ESET Security Management Center (Web Console), Version 7.1 (7.1.393.0)

Win 2008 standard R2 64 bit, MySQL 5.7.22.

Marcos, can you post a specific query?

I check my DB and tbl_tags tables are empty.

Edited by MarkE

Share this post


Link to post
Share on other sites

Related to

 

basically, it's the following query:

delete from dbl_tags_zig;

I'm assuming that's the same issue; if so, then yeah the above query should work (assuming that you don't have any existing tags).  I didn't, so I was able to delete all the entries.

Edmund

Share this post


Link to post
Share on other sites
On 12/19/2019 at 7:01 PM, Marcos said:

Is the ESMC running on a system powered by an older CPU without SSE4 instructions? If so, then it's a known issue. There's a workaround by running a specific query on the database that will delete all tags.

Hello, I checked my CPU by sysinternals coreinfo.exe. My CPU support SSE4. My problem were in two tables: tbl_tags_data and tbl_tags_metadata. I deleted records in that tables and ESMC is working OK.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...