Jump to content
agent47

Help with ESMC + ESET Endpoint + Agent (Latest Version)

Recommended Posts

Hi All,

A newbie here for ESMC and ESET stuffs. Would like to share my problems and seek for any inputs and assistance. I would provide as much details as I can so please bare with me :)

-- Everything down below are joined into a Domain --

  • 1) ESMC installed on Server 2012 R2 (used an All-in-one installer) and configured the basic one so meaning no proxy etc because Im on a testing phase for this version
  • 2) Desktop or client-side are Windows 10 Pro
  • 3) Firewall Policy are all set for this testing so meaning the Server to Client all services allowed vice versa
  • 4) Client-end Windows Firewall turned off completely
  • 5) ESET Server and Client can see each otherimage.thumb.png.cc400a5c4c02119b221ad3d28755b208.png

 

What I have done so far by means of exploring and playing around and such + Problems encountered

  • 1) Manually installed on client-side the agentx64.msi + eea_nt64.msi file to PC7 = ESMC able to see the PC7

image.png.76ab07a9fb7d705d078bc2f32f1da171.png

  • 2) Manually installed on client-side the agentx64.msi + eea_nt64.msi file to PC9 = ESMC are not able to see the PC9

image.png.6948a33bce59f31a4719ec6757182c2b.png

  • 3) Tried to use GPO Push installation for PC7 and PC9 and It was verified working upon testing frequently. However ended up the same as above issues.. ESMC cannot see any products installed for PC09 only..
  • 4) Uninstalled everything using a .bat file to wipe Agent and EEA application and to completely remove "C:\Program Files\ESET" folder to start a new test but unfortunately, problem was still there..

I am confused and stuck up. This only happened when I upgraded from the latest version of EEA 7.2 and Agent 7.1 as well as the ESMC Server 7.1.717.0

Quote

I do not have this kind of issue on my previous version. ESMC and Clients (800+) are all reporting and sync on my servers. I can manage them all at once If I wanted to using ESMC.

I have installed the latest ESMC All-in-one already and perform the basics as aforementioned :(

Another thing is I cannot perform Task Activation on PC7 even if I followed the guide from here.

Please see the attached Server Log and PC7 Log.

pc07.rar server.rar

Edited by agent47
spelling

Share this post


Link to post
Share on other sites

The log from the client shows

ERROR: InitializeConnection: Initiating replication connection to 'host: "localhost" port: 2222' failed with: GetAuthenticationSessionToken: Failed to fetch device session token in time

I assume that it should not be localhost where the ESMC server is running.

Share this post


Link to post
Share on other sites

Hi Marcos,

Thank you for the response. I have checked the Policy for Management Agent and the ESMC Server IP were already added.

I am sorry and Thank you

image.thumb.png.b9a9f94e7aebd2f5d0e18719531b17f4.png

Edited by agent47

Share this post


Link to post
Share on other sites

Hi Marcos,

I have double check the build-in policies. Saw some items that I have missed. Removed everything except the Custom Policies that I have created for this testing.

Will update here for the result.

Share this post


Link to post
Share on other sites

If necessary, reinstall or re-deploy the ESMC agent with a correct IP address of the ESMC server.

Share this post


Link to post
Share on other sites
21 minutes ago, Marcos said:

If necessary, reinstall or re-deploy the ESMC agent with a correct IP address of the ESMC server.

are you referring to installing the "ESMCAgentInstaller.bat" file Sir? I downloaded it from ESMC server and already run-as-administrator the .bat file

OR

should I remove and uninstall first the Agent on the problematic testpc then run this .bat file?

Thank you.

Share this post


Link to post
Share on other sites

It doesn't matter. If you run the batch file, view it and make sure it contains a correct IP address of the ESMC server. Alternatively you can run the agent msi installer and enter ESMC server's IP address in the installation wizard.

Share this post


Link to post
Share on other sites

From provided logs also it seems that peer certificate for AGENT might not be configured properly - it is not visible from screenshot but in case it is applied by any of your policies, please make sure it is correctly set with proper password if used.

Also as mentioned, as client is configured in a way it won't be possible to connect to ESMC, only possibility is to re-deploy, i.e. perform installation repair with new set of parameters. Technically any deployment method might be used, including manual installation, script based live installers and also bundle installers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...