Jump to content

Archived

This topic is now archived and is closed to further replies.

andre.s

Cant login in to remote administrator web console

Recommended Posts

Hello,

after a fresh install of server and Web-Console and changing the initial password, I cant login in to the Web-Console. The error is:

Login failed: Invalid username or password

In /var/log/eset/RemoteAdministrator/Server/trace.log I see this message:

2019-11-13 09:30:20 Error: CServerSecurityModule [Thread 7fa115ffb700]: AuthenticateNativeUser: Native user login failed

In Tomcat log I see this messages:

13-Nov-2019 10:30:20.968 INFORMATION [SocketLayer worker thread] sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter.addItem [2019-11-13 10:30:20.968] V2 [] <ERROR> Connection closing because of ERA server communication error: Message parsing error: java.io.IOException: SSL Engine reading side closed.
13-Nov-2019 10:30:20.969 INFORMATION [SocketLayer worker thread] sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter.addItem [2019-11-13 10:30:20.969] V2 [] <INFO> Closing connection
13-Nov-2019 10:30:20.969 INFORMATION [https-openssl-apr-443-exec-8] sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter.addItem [2019-11-13 10:30:20.969] V2 [Administrator] <WARNING> Login (session creation) failed (code 8) from address XXX.XXX.XXX.XXX.
13-Nov-2019 10:30:20.972 INFORMATION [https-openssl-apr-443-exec-8] sk.eset.era.g2webconsole.server.modules.logger.FileLogWriter.addItem [2019-11-13 10:30:20.969] V1 [Administrator] <TRACE> Login failed. Reason: name/password pair not authorized.


OS is Debian 9

ERA Server: 6.5.417.0

Web-Console: 6.5.388.0

Java: 8u232-b09-1~deb9u1

Tomcat: 8.5.14-1+deb9u3

 

What can I do that I can login in to the Web-Console?

 

Share this post


Link to post
Share on other sites

could you please check that database and MySQL ODBC driver you are using are listed as supported? Also what version of ESMC you are actually installing? Asking because we have released new version yesterday.

Few days ago similar issue was reported and problem what that unsupported ODBC driver was used - but this might have been resolved by recent release so I recommend to check

Share this post


Link to post
Share on other sites
47 minutes ago, andre.s said:

ERA Server: 6.5.417.0

Im afraid its not caused by new version of ESMC as he use ERA not ESMC

@andre.s do You use Administrator login for native user ?

Share this post


Link to post
Share on other sites

@Pinni3

yes I use Administrator to login.

 

@MartinK

Database version is MySQL 5.7.28-1debian9

libodbc1 is version 2.3.4-1

MySQL Connector is Version 5.3.14

Like Pinni3 said I install ERA Server and not ESMC

Share this post


Link to post
Share on other sites

Try to change Your console language to different as I saw in past random problems with login and that was only bypass.

Share this post


Link to post
Share on other sites

Please try this one :

Linux and Virtual Appliance users

To reset the Web Console Administrator password follow the steps below. The administrator password must be at least 8 characters long.

  1. Log in to the Linux console on the machine where ERA 6.5 is installed as root
     
  2. Save your password to the variable NEW_PASSWORD (for security reasons). Type following command, where <password> is substituted by your new password.
    export NEW_PASSWORD=<password>
     
  3. Run the following command to change your password for the new one:
    /opt/eset/RemoteAdministrator/Server/setup/installer_backup.sh --skip-license --server-root-password='env:NEW_PASSWORD'
     
  4. Run this command to remove your password from variables:
    export NEW_PASSWORD
     
  5. Restart the ERA Server service.

Share this post


Link to post
Share on other sites
51 minutes ago, andre.s said:

MySQL Connector is Version 5.3.14

This seems to be problem: latest/newest working ODBC driver is 5.3.10 If I recall correctly. Later 5.3 and 8.0 drivers are not working correctly with ESMC 7.0 which is probably problem you are experiencing.

Share this post


Link to post
Share on other sites

 

6 minutes ago, MartinK said:

This seems to be problem: latest/newest working ODBC driver is 5.3.10 If I recall correctly. Later 5.3 and 8.0 drivers are not working correctly with ESMC 7.0 which is probably problem you are experiencing.

MartinK, he is use ERA 6.5

Share this post


Link to post
Share on other sites

@MartinK if I install Version 5.3.10 it works. But why I have to use a version from 20-Jan-2018? And why are there are no hints in the docs that a special version must be used?

Share this post


Link to post
Share on other sites
1 hour ago, andre.s said:

@MartinK if I install Version 5.3.10 it works. But why I have to use a version from 20-Jan-2018? And why are there are no hints in the docs that a special version must be used?

Thanks for clarification. This limitations is actually described in ERA 6.5 documentation (Database requirements).
Regarding technical part of this problem, since version 5.3.11 it uses new codebase which contains issues affecting functionality of ERA/ESMC. They were reported and are tracked as MySQL issues, but they were not fixed to this time. That is why we introduced at least workaround in ESMC 7.1. On Windows, situation is even worse as drivers causes our application to crash.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...