Jump to content

ESMC VA cannot be antivirus defs mirror?


Mindflux
 Share

Recommended Posts

Is there a technical limitation to why ESMC cannot also host a definitions mirror?  If I use the mirror tool I have to use up one of my license seats to allow the tool to download updates... which ESMC should already do and distribute them for you. 

 

I skipped v6 of the entire line of products because of how wonky things were, v7 seems better but this would be great if ESMC could host the updates too...

 

 

Link to comment
Share on other sites

On ESET Security Management Center the mirror has been replaced with an Apache HTTP Proxy. Please see https://help.eset.com/esmc_install/70/en-US/apache_http_proxy.html

I think that is what you are looking for. Let me know.

Robbie // The Bald Nerd

Edited by BaldNerd
Link to comment
Share on other sites

When you first setup the VA there was a checkbox to enable it. You mustn't have spotted it during setup. It's easy to enable in the settings after the fact though, so no harm done.

No, I don't think it should be on by default. If the user is setting up the ESMC server behind a VPN or on the WAN, that would create a lot of unnecessary traffic as the devices check in. It's better to let the devices by default get their definitions directly from ESET's servers, and only proxy (mirror) them if specifically enabled by the admin.

Hope that helps!

Robbie // The Bald Nerd

Link to comment
Share on other sites

I do see in the docs there was a checkbox I missed.  I don't see how to enable it after the fact, without using SSH, though.. which has been done. I guess I'll see where this goes.

 

 

Link to comment
Share on other sites

Hi,

  I've done that. How do I confirm it's working?  I see data in the access_log, but I also see some messages like "AH01797: client denied by server configuration: proxy:esmc:2222" in the error_log.

 

I do see /var/cache/httpd has grown since last night.

 

Edited by Mindflux
Link to comment
Share on other sites

  • ESET Staff

@Mindflux You are right. If you have not selected the setting during VA setup, setting in server settings won´t enable it. You have following options: 

  1. Install HTTP proxy on a dedicated windows box, ideally using all in one isntaller
  2. Add it to the VA. AFAIK this steps should work: https://help.eset.com/era_deploy_va/65/en-US/enable_apache_http_proxy.html 
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...