Jump to content

Archived

This topic is now archived and is closed to further replies.

howardagoldberg

Android 10: Interesting Issue with Location, Permissions, and WiFi identification

Recommended Posts

I just upgraded my Pixel 3 (Verizon Wireless) from Android 9 to Android 10 on my secured home network.

Interesting issue encountered: After the update, ESET Mobile Security flagged my home network as an 'insecure public WiFi hotspot,' and recommended that I disconnect!

Reason? ESET had not been given location permissions and therefore could not resolve the SSID of the network (even though I was connected to the WiFi).

Giving ESET location permissions resolved the issue, no muss - no fuss.

So, just as a heads up: If network aware apps aren't working correctly (security apps, WiFi/Network scanning apps, apps that sync over WiFi such as DejaOffice) after updating to Android 10, make sure you give those apps location permissions.

As an aside, hopefully ESET folks will test this themselves, and roll out an update to account for this change in Android 10 so less savvy users do not become concerned that they are suddenly connecting to a non-secure public network from their home! ūüėȬ†

@Marcos

Share this post


Link to post
Share on other sites

This does not work for me. Location permission is enabled for eset.

Share this post


Link to post
Share on other sites
47 minutes ago, MikeO3 said:

This does not work for me. Location permission is enabled for eset.

Thoughts:

1) Is the permission for location set to 'always' or 'just when app is in use?' It needs to be set for always.

2) Are you certain that the WiFi network you are on is actually secure (WPA2 or better)?

3) After setting the location permission for ESET, toggle your WiFi off, let the phone connect to LTE, then turn the WiFi back on. I had to toggle the WiFi in order for ESET to 're-scan' the network I was connected  to.

Hope that helps!

Share this post


Link to post
Share on other sites
2 hours ago, howardagoldberg said:

Thoughts:

1) Is the permission for location set to 'always' or 'just when app is in use?' It needs to be set for always.

Yes, Always...

2) Are you certain that the WiFi network you are on is actually secure (WPA2 or better)?

Yes, it is my home network.

3) After setting the location permission for ESET, toggle your WiFi off, let the phone connect to LTE, then turn the WiFi back on. I had to toggle the WiFi in order for ESET to 're-scan' the network I was connected  to.

This worked and appears to have solved the problem. i ran an audit and now the error is no longer reported.

Hope that helps!

Thanks for you help and quick response.

1. Yes, it is Always.

2. Yes, WPA2 personal (this is my home network WiFi)

3. Disconnect & reconnect WiFi worked.

 

Thank you for your suggestions as it appears to be resolved now after an scan and reviewing the audit summary.

Share this post


Link to post
Share on other sites

I was having the same issue on a Pixel 2 after the Android 10 update. Permissions were set to Always. Disconnect/reconnect to home WiFi fixed the error.

Thanx.

Share this post


Link to post
Share on other sites

Thanks!  I had the same issue with a Pixel XL after upgrading to Android 10.  Giving ESET Location always permission, and toggling wi-fi off and on cleared it up.

Share this post


Link to post
Share on other sites

@Marcos @Peter Randziak

Late last week, ESET Mobile Security for Android was updated on my device to version 5.2.18.0. With the update, this issue has returned with somewhat different symptoms, but it is easily reproducible:

1) While on my home network, no 'warnings' from ESET.

2) If I leave my home, keep WiFi on (but not connected, obviously), phone automatically switches to LTE, no issues.

3) RETURN home. Phone reconnects to home WiFi network. Now, ESET throws a warning that I am connected to an insecure network and I should disconnect.

4) Toggle WiFi off. Toggle WiFi on, issue 'resolves.'

But obviously, it's a bit of an annoyance to have to toggle WiFi off and on again on my home network that is fully secured. Clearly, this is a bug.

I am running the latest version of Android 10 (with both the system and 'play' October security patches) on a Pixel 3 running on Verizon wireless.

Location setting for the app is to allow location access at all times.

Please advise. Thank you!

Share this post


Link to post
Share on other sites
On 10/20/2019 at 1:51 PM, howardagoldberg said:

@Marcos @Peter Randziak

Late last week, ESET Mobile Security for Android was updated on my device to version 5.2.18.0. With the update, this issue has returned with somewhat different symptoms, but it is easily reproducible:

1) While on my home network, no 'warnings' from ESET.

2) If I leave my home, keep WiFi on (but not connected, obviously), phone automatically switches to LTE, no issues.

3) RETURN home. Phone reconnects to home WiFi network. Now, ESET throws a warning that I am connected to an insecure network and I should disconnect.

4) Toggle WiFi off. Toggle WiFi on, issue 'resolves.'

But obviously, it's a bit of an annoyance to have to toggle WiFi off and on again on my home network that is fully secured. Clearly, this is a bug.

I am running the latest version of Android 10 (with both the system and 'play' October security patches) on a Pixel 3 running on Verizon wireless.

Location setting for the app is to allow location access at all times.

Please advise. Thank you!

@Marcos @Peter Randziak ... ^^^ any thoughts? I just left my house to run an errand. When I returned, and the phone reconnected to WiFi, ESET is throwing up the 'insecure network' notification. This is def a bug ...

Share this post


Link to post
Share on other sites
On 10/23/2019 at 12:42 PM, howardagoldberg said:

@Marcos @Peter Randziak ... ^^^ any thoughts? I just left my house to run an errand. When I returned, and the phone reconnected to WiFi, ESET is throwing up the 'insecure network' notification. This is def a bug ...

 

On 10/20/2019 at 1:51 PM, howardagoldberg said:

@Marcos @Peter Randziak

Late last week, ESET Mobile Security for Android was updated on my device to version 5.2.18.0. With the update, this issue has returned with somewhat different symptoms, but it is easily reproducible:

1) While on my home network, no 'warnings' from ESET.

2) If I leave my home, keep WiFi on (but not connected, obviously), phone automatically switches to LTE, no issues.

3) RETURN home. Phone reconnects to home WiFi network. Now, ESET throws a warning that I am connected to an insecure network and I should disconnect.

4) Toggle WiFi off. Toggle WiFi on, issue 'resolves.'

But obviously, it's a bit of an annoyance to have to toggle WiFi off and on again on my home network that is fully secured. Clearly, this is a bug.

I am running the latest version of Android 10 (with both the system and 'play' October security patches) on a Pixel 3 running on Verizon wireless.

Location setting for the app is to allow location access at all times.

Please advise. Thank you!

^^^ This is still an issue. Any updates @Marcos?

Share this post


Link to post
Share on other sites

Still a problem for me. I disabled eset wifi network checking.

Share this post


Link to post
Share on other sites
On 10/25/2019 at 9:49 PM, howardagoldberg said:

 

^^^ This is still an issue. Any updates @Marcos?

You might find opening a ticket will get a better result as mods don't always read everything on here. 

Share this post


Link to post
Share on other sites

Hello @howardagoldberg,

I noticed similar behavior during Connected home scan.

The issue (feature) is caused by the Android permissions i.e. if an application wants to know the SSID of a WIFI, the permissions to read location had to be granted and the Location services enabled...

Peter

Share this post


Link to post
Share on other sites
11 minutes ago, Peter Randziak said:

Hello @howardagoldberg,

I noticed similar behavior during Connected home scan.

The issue (feature) is caused by the Android permissions i.e. if an application wants to know the SSID of a WIFI, the permissions to read location had to be granted and the Location services enabled...

Peter

Correct. But I gave ESET full location permissions, and the issue persists. Giving location permissions actually solved the issue right after the release of Android 10, but a more recent update to the ESET app reintroduced the issue - even if ESET has location permissions granted. (Currently my app is at version 5.2.42.0-0)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...