Jump to content
cspacone

Sluggish Outlook Performance

Recommended Posts

Posted (edited)

Environment:

Microsoft Office Professional 2016 running under Windows 10 Professional with latest updates.

Outlook Version 1907 (Build 11901.20218 click-to-run)

Eset NOD32 12.2.23.0

 

Behaviour noted:

When initially starting outlook the application takes up to 90 seconds to begin the send/receive mail process. If I disable NOD32 and restart Outlook it begins to check email very quickly, perhaps 120 seconds or less.

 

I note that this is not new behaviour, Outlook has done this under NOD32 for as long as I can remember. Although this is only an annoyance, I would like to be able to correct this if possible.

 

My apologies in advance if this question has been asked and answered; I did try several search terms but could not find a suitable match.

regards,

-Chris

Edited by cspacone
added additional informatin regarding operating environment.

Share this post


Link to post
Share on other sites

Do you receive email via IMAP(S)/POP3(S) or via MAPI from an Exchange server?
Does temporarily disabling integration with MS Outlook make a difference?
Does temporarily leaving only scanning of incoming email make a difference?

Share this post


Link to post
Share on other sites

I receive mail using POP3, no Exchange integration at all.

Disabling integration with Outlook restores expected performance.

I have not tried temporarily disabling scanning of incoming mail, I will do so and report back.

Share this post


Link to post
Share on other sites

Temporarily disabling email protection has no positive impact on the speed at which Outlook checks and downloads messages from the POP3 server.

268449450_outlooksendreceive.png.691018dbe16c3097fd647f67c9bebe34.png Sits ion this state for up to 1 minute or so.

This is where I went to temporarily disable Outlook integration:

533101206_internetprotection.png.07c220a1abe35b36bdcced35009a2d50.png

 

 

 

 

Share this post


Link to post
Share on other sites

Doing this results in Outlook contacting the POP3 server and downloading messages within 6 seconds or so.

 

Clearly, turning off AV is not something I intend to do! And as I'd stated earlier, if this is typical behaviour then I'll deal with the inconvenience. Just wanted to see if it was something that I was doing that could be easily corrected.

-Chris

 

303499795_disablefor4hours.png.d7d3ab0a26a9f53fa9e7def179ede372.png

Share this post


Link to post
Share on other sites
1 hour ago, cspacone said:

This is where I went to temporarily disable Outlook integration:

First, check mark the option shown in the below screen shot. Save your change. See if that speeds up e-mail reception.

If not, then uncheck mark the option "Integrate into Microsoft Outlook"  on the same screen. Save your change. See if that speeds up e-mail reception.

Do not disable Eset E-mail protection since e-mail will not be scanned in any fashion. Never disable the Anti-virus protection.

Eset_Email.thumb.png.2ae0b1ada2d55cf1196ddc0665ac0cfc.png

Edited by itman

Share this post


Link to post
Share on other sites

@itman your solution works. Outlook now contacts the POP3 server and begins downloading withing a few seconds of launching Outlook.

 

Share this post


Link to post
Share on other sites

@Marcos  Disabling "...client plugins" also make Outlook respond within a few seconds of launching.

 

Did not check the protocol filtering option.

 

Q: between your suggestion and itman's, which would be the preferred method and why?

Share this post


Link to post
Share on other sites
35 minutes ago, cspacone said:

Q: between your suggestion and itman's, which would be the preferred method and why?

Disabling inbox content change is the best solution since its not disabling any of Eset's protection mechanisms.

Share this post


Link to post
Share on other sites

My boss at work has this same issue and I had to disable Email filtering for him. I wish ESET would fix this sluggish performance issue so we don't need to disable it completely.

Share this post


Link to post
Share on other sites

Please contact customer care. It's necessary to narrow it down to read or sent email and then use a logging version of the Outlook plug-in to generate logs for perusal.

Share this post


Link to post
Share on other sites
On 10/7/2019 at 11:53 AM, Ultra Male said:

My boss at work has this same issue and I had to disable Email filtering for him. I wish ESET would fix this sluggish performance issue so we don't need to disable it completely.

Did you do what I posted previously? Namely enable the option "Disable checking upon inbox content change."

If that doesn't help, next uncheck mark the option "Integrate into Microsoft Outlook"  on the same screen. Eset will still scan all incoming POPS or MAPS protocol traffic.

You do not want to totally disable Eset's E-mail filtering protection.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...