Jump to content

Archived

This topic is now archived and is closed to further replies.

IT Support OZG

Error: CSystemConnectorModule [Thread 11f4]: Software installation failed: GetFile: Error reading HTTP response data (0x4e33)

Recommended Posts

Hi,

we have ESMC Server Version 7.0 (7.0.577.0). I've installed agent from console successfullya but when I am pushing installation from our console I am getting this error: Failed to synchronize package repository. See trace message for more details.

Then i found this: 2019-08-20 11:59:13 Error: CSystemConnectorModule [Thread 11f4]: Software installation failed: GetFile: Error reading HTTP response data (0x4e33)

which I found at client side at trace.log in path: \\computername\c$\ProgramData\ESET\RemoteAdministrator\Agent\EraAgentApplicationData\Logs\trace.log

Error is produced while I was trying to push install of latest version of Eset Endpoint Security over WAN link.

Please can somebody help me.

Thanks in advanced.

Best regards

Share this post


Link to post
Share on other sites

ESET Endpoint is not installed via a push installation but instead you send a software install task to a client (agent) and it downloads the installer from a repository or your local share, depending on the configuration of the task.

Do you have agent already installed on machines where you want to install ESET Endpoint? Do the clients have access to ESET's repository, activation servers, etc. as per https://support.eset.com/kb332/#era6 ? Do they connect directly to the Internet or through a proxy? If the latter, is the proxy server configured properly in an agent's policy? Are the clients behind a firewall that might prevent agent from accessing the repository?

Share this post


Link to post
Share on other sites

Hey there,

I've had this problem before
I'm guessing that you have the apache http proxy installed on the esmc server as well.
in such cases, the agent will have automatically the agent policy which provide the apache ip address under http proxy section  "mostly the same ip address of the ESMC server" .
if you have a week internet speed, the apache will fail to download the msi packet and will report the mentioned error.
to solve this you need to increase the apache timeout setting:
* under C:\Program Files\Apache HTTP Proxy\conf. you will find httpd.conf
* when editing the file. search for Proxytimeout 900 and change it to ProxyTimeOut 1200
* add an extra line Timeout 120
* save the changes and restart the apache service. it should work 

Share this post


Link to post
Share on other sites
On 8/20/2019 at 4:23 PM, Marcos said:

ESET Endpoint is not installed via a push installation but instead you send a software install task to a client (agent) and it downloads the installer from a repository or your local share, depending on the configuration of the task.

Do you have agent already installed on machines where you want to install ESET Endpoint? Do the clients have access to ESET's repository, activation servers, etc. as per https://support.eset.com/kb332/#era6 ? Do they connect directly to the Internet or through a proxy? If the latter, is the proxy server configured properly in an agent's policy? Are the clients behind a firewall that might prevent agent from accessing the repository?

Hi Marcos,

Yes, I mean on - software install task like you said in this case from repository.
Yes, I have agent already installed. In VPN tunnel all traffic is allowed (From any to any) and they connect directly to the internet through Fortigate 81E series router.

Their computer object is in AD OU for which is created policy where Windows FIREWALL is on but I allowed File and Print sharing and port 2222 for communication with ESMC console.

I tried to do what Farah said but it did not help... I still have the same error in trace.log on that computer.

From my experience I had many different reasons for this info when it is failed: Failed to synchronize package repository See trace message for more details

- Remote registry disabled
- Forticlient RealTimeProtection turned on
- DNS client service disabled
- computer did not applied my windows policy

but i solve all of this cases.

I just have this errors :( GetFile: Error reading HTTP response data (0x4e33)

Share this post


Link to post
Share on other sites
On 8/21/2019 at 10:48 AM, Farah said:

Hey there,

I've had this problem before
I'm guessing that you have the apache http proxy installed on the esmc server as well.
in such cases, the agent will have automatically the agent policy which provide the apache ip address under http proxy section  "mostly the same ip address of the ESMC server" .
if you have a week internet speed, the apache will fail to download the msi packet and will report the mentioned error.
to solve this you need to increase the apache timeout setting:
* under C:\Program Files\Apache HTTP Proxy\conf. you will find httpd.conf
* when editing the file. search for Proxytimeout 900 and change it to ProxyTimeOut 1200
* add an extra line Timeout 120
* save the changes and restart the apache service. it should work 

Thank you Farah.

I tried but in my case it did not help :(

Share this post


Link to post
Share on other sites
21 hours ago, Marcos said:

Fortigate is known to corrupt some files. See

Try activation bypassing Fortigate, if possible.

Do you maybe recommend creating an exception if it is possible ? And which and where ?

Share this post


Link to post
Share on other sites

Since I don't have any personal experience with Fortigate, I can only suggest to contact Fortigate's support. I was able to find only the following article but that's rather only for blocking or allowing access to particular urls:

https://help.fortinet.com/fclient/olh/5-6-1/FortiClient-5.6-Admin/1000_Web Security & Filter/0610_Manage exclusion list.htm

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...