Jump to content

BSOD caused by uninstall of Internet Security

Recommended Posts


Today I removed Eset Internet Security from my main Windows 7 Pro 64bit installation (currently booted into a second windows 7 writing this) via 'Programs and Features' and after rebooting I had a blue screen of death. The big problem is also I cannot boot into safe mode either, because as soon as it lists the drivers in white text on the black backround it jumps to the same blue screen error. I've tried researching the issue and found that you should delete any Eset 'company' files and folders in system32 drivers folder and in program files and app data but there is a problem deleting (Users\All Users\ESET\ESET Security) as it will not allow to rename/delete any of the files or folders inside that main ESET folder as it gives error:

Folder access denied

You need permission to perform this action

You need permission from SYSTEM to make changes to this folder

Edit: In the last few minutes I have realised that I can rename 'All Users' folder (which by the way shows a gold lock on the folder) to 'All Users2' and creating a new 'All Users' folder and copying all the other folders and files from it EXCEPT 'ESET' folder into it. There were a few dozen errors about files that cannot be copied back into the 'All Users' folder because of permissions but they don't seem to be important (they are .rbs files and a few other types) but at this point I just want to boot into Windows as normal as it's my main system and I am certain Eset has caused this as everything was normal this morning until I uninstalled and rebooted the system. I've had this Windows 7 running on SSD for a good while and I've customised it as we all do that I really need to restore. Note I do have backups of this Windows 7 installation disk but they are not as up-to date as recently as I'd like but it's possible I can revert to this if I cannot fix this BSOD issue.


Another thing I've tried is system restore from a bootable usb but it states I do not have any restore points which is odd as I'm sure I set aside around 8-9GB just for this function.


I've also tried startup repair numerous times but it stated after a few minutes that it cannnot repair automatically. I checked the log and there are a few error messages but I will have to try again as I did not note exactly what it said but it was along the lines of 'unspecified hardware....' sorry I don't remember much to be honest.


I really should have uninstalled using the specific tool in safe mode but I completely forgot that at the time. And as I can't even boot into safe mode that is kind of impossible right now.


Thanks for your time.

Link to comment
Share on other sites

  • Administrators

Starting Windows in safe mode is not possible only if the Device Control driver edevmon.sys has been removed from the disk without being correctly unregistered from a filter chain.

A solution is to boot from another medium (e.g. SysRescue) and copy edevmon.sys from another machine with the same OS and ESET installed to C:\Windows\System32\drivers.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...