Jump to content

ESET Remote Adminstration ODBC Issue


B.Gillissen
 Share

Recommended Posts

Hi i m trying to install the Remote Administration server on a debian buster.

the installation fails on the ODBC Mysql DB connection, i tried all 3 ODBC instances with the same results :

# sh ./server-linux-x86_64.sh --skip-license --db-driver="MySQL" --db-hostname="localhost" --db-port="3306" --db-admin-username="root" --db-admin-password="trucmush" --server-root-password="trucmush" --db-user-username="eset" --db-user-password="eset" --cert-hostname="localhost"

ESET Remote Administrator Server Installer (version: 6.5.417.0), Copyright © 1992-2017 ESET, spol. s r.o. - All rights reserved.

Extracting archive, please wait...
Archive extracted to /tmp/tmp.byFEfYt3cY.
Checking OpenSSL ... done [OpenSSL 1.0.2s 28 May 2019]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Checking database connection ... failure

Error: An error occurred while trying to connect to the database. Error code: (2002). Unable to continue.

Here are some informations about my environment:

# find /usr -iname "*libmyodbc*"
/usr/local/lib/libmyodbc5S.so
/usr/local/lib/libmyodbc5a.so
/usr/local/lib/libmyodbc5w.so
# cat /etc/odbcinst.ini
[MySQL ODBC 5.3 Driver]
Driver=/usr/local/lib/libmyodbc5w.so

[MySQL ODBC 5.3]
Driver=/usr/local/lib/libmyodbc5a.so

[MySQL]
Description=ODBC For MySQL
Driver=/usr/local/lib/libmyodbc5a.so
Setup=/usr/local/lib/libmyodbc5S.so
FileUsage=1
# odbcinst --version
unixODBC 2.3.6
# mysql -hlocalhost -u root -p
Enter password:
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 39
Server version: 10.3.15-MariaDB-1 Debian 10

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]>

Kind Regards Ben.

 

 

Link to comment
Share on other sites

Ok, i got i the install script working,

Not sure it was related to mariadb / mysql, as i switched to mysql; but when --db-hostname is set to localhost, odbc uses a socket, setting it to 127.0.0.1 make it actually use a tcp/ip connection.

Link to comment
Share on other sites

  • Administrators

Still, MariaDB is not officially supported. While it may seem to work, you may run into issues later. Please consider changing the db to MySQL.

Link to comment
Share on other sites

Now, i m facing another issue, after the first login on the web console. it requires me to change the 'root' password has it is marked as expired. But once i do so, neither the new or old password allows me to get in.

 

Edit: i m using mysql now.

Edited by B.Gillissen
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...