Jump to content

Archived

This topic is now archived and is closed to further replies.

Cody

ESET disrupts audio w/small CPU usage spikes (Endpoint Security 7.1.2045)

Recommended Posts

When a computer is run for more than about 48 hours, and any audio is played using any software, ESET will frequently spike from it's normal 0% of CPU usage to about 1%. This would ordinarily be fine, but every time the CPU usage spikes, at least once every two minutes, the audio on the computer becomes "glitchy" or "artifacted." This lasts for about 1-3 seconds, and the audio is totally unintelligible during this time. This is unacceptable for employees whose work duties include working with digital music files and listening to customer voicemails.

This is happening on several Windows 10 devices in our office with Intel Core i5-7500 CPU @ 3.40GHz, and 8+ GB of RAM. When ESET is uninstalled, this does not happen. We have observed and reported this bug since version 6, about a year ago. We have been using version 5 for the last year while I was waiting for this bug to be fixed, but apparently that hasn't happened. Any advice?

Thanks.

Share this post


Link to post
Share on other sites

Please narrow it down as follows, by trying one thing at a time:
- pause protection
- disable HIPS and reboot the machine
- rename drivers as follows:

  1. in safe mode, rename "C:\Program Files\ESET\ESET Security\Drivers" to Drivers_bak
  2. also rename the following drivers, one at a time and see if the issue goes away:
    C:\Windows\System32\drivers\eamonm.sys
    C:\Windows\System32\drivers\ehdrv.sys

Let us know which of the above steps makes the issue go away.

Share this post


Link to post
Share on other sites

Marcos,

Sorry for the delay. After making each of these changes, I have to wait a few days just to verify whether the problem occurs again or not.

I've tried everything, and the problem has stopped. On the machine that I have been testing on, this is the current state:

  • HIPS is disabled, and machine has been rebooted
  • In Safe Mode, C:\Program Files\ESET\ESET Security\Drivers has been renamed to C:\Program Files\ESET\ESET Security\Drivers_bak
  • In Safe Mode, C:\Windows\System32\drivers\ehdrv.sys has been renamed to C:\Windows\System32\drivers\ehdrv.sys.old
  • Machine has been rebooted and problem does not seem to be occurring

Share this post


Link to post
Share on other sites

Now try re-enabling HIPS (don't forget to rename Drivers_bak back to Drivers) but disable:
- Advanced Memory Scanner
- Self-defense

Let us know if the problem returns or if it works without issues. If the issue doesn't occur, try enabling self-defense and test it for a while. Then re-enable AMS and make another test.

Share this post


Link to post
Share on other sites

After re-enabling HIPS and leaving AMS and self-defense turned off, the problem appears to have started occurring within a day.

Share this post


Link to post
Share on other sites

Just checking to see if you ever received my response to this post. When I leave HIPS re-enabled, the audio problem occurs again. Any suggestions?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...