Jump to content
Nova

Update problems - ESET File/Mail/Gateway Security for Linux/FreeBSD version 4.5.15.0

Recommended Posts

Posted (edited)

Again, after sucessfull updates i see on my 2 Servers (Ubuntu Server 16.04) again errors in the syslog file that the update was not sucessfull. With manually started updates from the shell ./esets_update --verbose i get on both that 3 files are corrupted, after i got the updates fixed in the night after several times of manually start the update from the shell (./esets_update) - on both servers!

As both servers are located in different data centers i believe your update files or servers are the reason, there is no proxy or something between my servers and the update servers. Over time it's annoying that this issue appears very often in some cases i could only fix it by copying the em*.dat files and whole lib folder from one server where the update is working to the other server where the update files are corrupted again.

  • Re-installation of the ESET Gateway Security as descriped in your manual doesn't fix the issue.
  • Removing/moving  the emu and dup files doesn't fix the issue.

Without regular updates the product is useless? What's the solution?

 

 

 

 

Edited by Nova

Share this post


Link to post
Share on other sites
8 hours ago, Nova said:

Again, after sucessfull updates i see on my 2 Servers (Ubuntu Server 16.04) again errors in the syslog file that the update was not sucessfull. With manually started updates from the shell ./esets_update --verbose i get on both that 3 files are corrupted, after i got the updates fixed in the night after several times of manually start the update from the shell (./esets_update) - on both servers!

As both servers are located in different data centers i believe your update files or servers are the reason, there is no proxy or something between my servers and the update servers. Over time it's annoying that this issue appears very often in some cases i could only fix it by copying the em*.dat files and whole lib folder from one server where the update is working to the other server where the update files are corrupted again.

  • Re-installation of the ESET Gateway Security as descriped in your manual doesn't fix the issue.
  • Removing/moving  the emu and dup files doesn't fix the issue.

Without regular updates the product is useless? What's the solution?

 

 

 

 

It is needed to do the following steps to fix the issue because some of the modules are probably corrupted.
The best way is to stop the service, clean update cache, delete the modules and download completely fresh update files and modules will be recompiled and added to /var/opt/eset/esets/lib

- stop service
- delete content of modules directory /var/opt/eset/esets/lib
- clean the update cache directory /var/opt/eset/esets/lib/data/updfiles
- clean logs direcotry /var/log/esets/
- run update manually deleted modules will be replaced for fresh /opt/eset/esets/sbin/esets_update --verbose
- once update is successfully done you can start the service

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you J.J. that worked for 1 Server hopefully it will last for a while! 

On the second server it doesn't work with these instructions got "Error downloading update.." had to purge the deb packet.

After reinstallation the update works but on the first server i had newer files:

+-+--------------------+------------------------+------------------------+
| | Module             | Available version      | Installed version      |
+-+--------------------+------------------------+------------------------+
| | loader             |        1072 (20180813) |        1072 (20180813) |
| | perseus            |      1551.1 (20190424) |      1551.1 (20190424) |
|*| engine             |       19412 (20190524) |       19411 (20190524) |
| | archiver           |        1287 (20190516) |        1287 (20190516) |
| | heuristic          |        1192 (20190204) |        1192 (20190204) |
| | cleaner            |        1192 (20190507) |        1192 (20190507) |
+-+--------------------+------------------------+------------------------+
 

as on the backup server:

Virus signature database has been updated successfully.
ESETS Update utility
+-+--------------------+------------------------+------------------------+
| | Module             | Available version      | Installed version      |
+-+--------------------+------------------------+------------------------+
| | loader             |        1072 (20180813) |        1072 (20180813) |
| | perseus            |      1549.3 (20190326) |      1549.3 (20190326) |
| | engine             |       18779 (20190128) |       18779 (20190128) |
| | archiver           |        1285 (20190313) |        1285 (20190313) |
| | heuristic          |        1192 (20190204) |        1192 (20190204) |
| | cleaner            |        1183 (20190305) |        1183 (20190305) |
+-+--------------------+------------------------+------------------------+
 

How to fix that without corrupting the installation again?

thx

Edited by Nova

Share this post


Link to post
Share on other sites
On 5/24/2019 at 7:43 PM, Nova said:

Thank you J.J. that worked for 1 Server hopefully it will last for a while! 

On the second server it doesn't work with these instructions got "Error downloading update.." had to purge the deb packet.

After reinstallation the update works but on the first server i had newer files:

+-+--------------------+------------------------+------------------------+
| | Module             | Available version      | Installed version      |
+-+--------------------+------------------------+------------------------+
| | loader             |        1072 (20180813) |        1072 (20180813) |
| | perseus            |      1551.1 (20190424) |      1551.1 (20190424) |
|*| engine             |       19412 (20190524) |       19411 (20190524) |
| | archiver           |        1287 (20190516) |        1287 (20190516) |
| | heuristic          |        1192 (20190204) |        1192 (20190204) |
| | cleaner            |        1192 (20190507) |        1192 (20190507) |
+-+--------------------+------------------------+------------------------+
 

as on the backup server:

Virus signature database has been updated successfully.
ESETS Update utility
+-+--------------------+------------------------+------------------------+
| | Module             | Available version      | Installed version      |
+-+--------------------+------------------------+------------------------+
| | loader             |        1072 (20180813) |        1072 (20180813) |
| | perseus            |      1549.3 (20190326) |      1549.3 (20190326) |
| | engine             |       18779 (20190128) |       18779 (20190128) |
| | archiver           |        1285 (20190313) |        1285 (20190313) |
| | heuristic          |        1192 (20190204) |        1192 (20190204) |
| | cleaner            |        1183 (20190305) |        1183 (20190305) |
+-+--------------------+------------------------+------------------------+
 

How to fix that without corrupting the installation again?

thx

It work for me when I deleted modules and updated using esets_update. This looks that something else is corrupted or some other issue with download. It is strange if both updates directly from ESET servers. It should work when you clean the cache and modules that all will be downloaded completely fresh.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...