Jump to content

Archived

This topic is now archived and is closed to further replies.

817

database create error occurred during ESMC install

Recommended Posts

OS: CentOS Linux 7.6.1810
mySQL:5.7

I tried to install ESMC and run Server-Linux-x86_64.sh, got the database create error.
I checked /var/log/mysqld.log and see the "Got an error reading communication packets" so
change the parameter in /etc/my.cnf,

max_allowed_packet=33M
innodb_log_file_size=200M
innodb_log_files_in_group=20
character-set-server=utf8

but, nothing change.

Do you have any idea?

---

ESET Security Management Center Server Installer (version: 7.0.472.0), Copyright © 1992-2018 ESET, spol. s r.o. - All rights reserved.


Product improvement program
Participating in product improvement program includes sending crash reports and anonymous telemetry data such as OS version and type, ESET product version and other product-specific information to ESET when enabled.

Do you want to participate in the Product improvement program? [Y/n]: 

Extracting archive, please wait...
Archive extracted to /tmp/tmp.aNsol9Mi64.
Checking OpenSSL ... done [OpenSSL 1.0.2k-fips 26 Jan 2017]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Checking database connection ... done
Checking database user ... done
Loading GUID ... done [GUID = 28c8f460-3550-4b5c-a0bc-09f4e4bc5c37]
Inserting root password ... done
Generating certificates ... done
Skipping static groups synchronization scheduling.
Stopping service... Preparing database upgrade ... done
Upgrading database ..../x64/Server-Linux-x86_64.sh: 2549 行:  3656 中止                  (コアダンプ) "${tmp_install_prefix}/setup/$ca_wrapper_bin" -a DbUpgrade --locale "$arg_locale" --modules-dir "${tmp_install_prefix}/setup/Modules/" --db-type "$arg_db_type" --db-driver "$arg_db_driver" --db-hostname "$arg_db_hostname" --db-port "$arg_db_port" --db-name "$arg_db_name" --db-user-username "$arg_db_user_username" --db-user-password "$arg_db_user_password" --db-scripts-dir "$tmp_db_scripts_dir" --db-connectors-dir "$arg_db_connectors_dir" --product-guid "$GUID" --product-name "$product_name" --silent-reinstall "$arg_silent_reinstall" --current-version "$arg_current_version" 2>> "$installer_log_file"
 failure

Error: 2564: Error occurred while upgrading database

Share this post


Link to post
Share on other sites

Could you please provide also /var/log/eset/RemoteAdministrator/EraServerInstaller.log  -> it contains ESMC installer log. There is only one suspicious entry in provided output, and it is "2549 行:  3656 中止                  (コアダンプ) ": could you help us interpret it? Is it possible you have some non-US locale set in terminal used for installation?

In case you are performing new installation, please make sure that before each attempt of installation, ESMC database is removed, it is most probably in undefined state after such failure.

Share this post


Link to post
Share on other sites

Thank you @MartinK, Here's EraServerInstaller.log.

 "2549 行:  3656 中止                  (コアダンプ) " is
" Row No.2549 : 3656  stopped  (core dump) ". 

but I don't know the mySQL error message on English environment, it may different actually message in English. 

The parameter of Server-Linux-x86_64.sh is below, passwords are masked, and these parameter is written in Japanese ESMC installation manual.

./x64/Server-Linux-x86_64.sh \
--locale=ja_JP \
--skip-license \
--db-driver=MySQL \
--db-hostname=127.0.0.1 \
--db-port=3306 \
--db-admin-username=root \
--db-admin-password=********** \
 --server-root-password=*********** \
--db-user-username=era_server_user \
--db-user-password=********** \
--cert-hostname=*
 

EraServerInstaller.log

Share this post


Link to post
Share on other sites

Problem seems to be in MySQL ODBC driver used. Unfortunately ESMC 7.0 does not support latest versions as there is some bug in driver itself. It was supposed to be fixed in ODBC driver 8.0.16 released recently but seems there might be some another issue.

I would recommend to check documentation where latest supported version of MySQL ODBC driver is mentioned. If I recall correctly, latest working version is 5.3.10.

Share this post


Link to post
Share on other sites

I checked the version ODBC-driver and re installed 5.3.10, then ESMC installer run correctly.

Thank you very much, @MartinK and @Peter Randziak !

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...