Jump to content

Archived

This topic is now archived and is closed to further replies.

RajGopalBH

Equvivalent for libcanberra-gtk-module:i386,libappindicator1

Recommended Posts

Dear Eset ,

 

I am trying to install eset nod 32 antivirus in Fedora 29 operating system . Earlier I used Ubuntu 18.04 and I had to type this command 

"sudo apt-get install libcanberra-gtk-module:i386 " for installing antivirus  but Now I am confused with Fedora OS  .

Can anyone specify the equivalent packages in fedora 29 so that I can proceed with installation ?

Before installation I disabled selinux in this way .

sudo sed -i 's/selinux=enforcing\|selinux=permissive/SELINUX=disabled/I' /etc/selinux/config .

 

Please some one guide me to install this software in fedora 29 .

Share this post


Link to post
Share on other sites
On 4/21/2019 at 12:58 PM, RajGopalBH said:

Dear Eset ,

 

I am trying to install eset nod 32 antivirus in Fedora 29 operating system . Earlier I used Ubuntu 18.04 and I had to type this command 

"sudo apt-get install libcanberra-gtk-module:i386 " for installing antivirus  but Now I am confused with Fedora OS  .

Can anyone specify the equivalent packages in fedora 29 so that I can proceed with installation ?

Before installation I disabled selinux in this way .

sudo sed -i 's/selinux=enforcing\|selinux=permissive/SELINUX=disabled/I' /etc/selinux/config .

 

Please some one guide me to install this software in fedora 29 .

Disable Selinux (Selinux is not supported by our product):

To disable SELinux, configure SELINUX=disabled in /etc/selinux/config:
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#       targeted - Targeted processes are protected,
#       mls - Multi Level Security protection.
SELINUXTYPE=targeted

Disable Wayland (Wayland is not supported by our product)
You can do this on Fedora 29 by editing /etc/gdm/custom.conf and uncommenting the line "#WaylandEnable=false"

Install GlibC
- yum install libc6.i686

Install Gnome tweak tool:
- yum install gnome-tweak-tool

Install TopIcons Extension:
- yum install gnome-shell-extension-topicons-plus

Pre-Requisities: You need the make utility :
# Debian, Ubuntu
sudo apt-get install make
# Red Hat, Fedora
sudo dnf install make
Download the code to any folder, using git:
git clone https://github.com/phocean/TopIcons-plus.git

Go into the TopIcons Plus project directory and execute the installation script.
cd TopIcons-plus
make install

This will compile the glib schemas and copy all the necessary files to the GNOME Shell extensions directory for your own user account (so you don't need admin privileges to run make). By default, TopIcons Plus will live in the directory 
~/.local/share/gnome-shell/extensions/TopIcons@phocean.net/.

If you want to install the extension so that it will be usable system-wide, you'll have to change the INSTALL_PATH variable, and run as root.
sudo make install INSTALL_PATH=/usr/share/gnome-shell/extensions

Finally, launch the gnome-tweak-tool utility to manage extensions. There, you can enable TopIcons Plus and then tweak its look and feel.

Enable Top Icons plus using Gnome Tweak tool
- Screenshot attached

topicons01.jpg?version=1&modificationDat

Install ESET NOD32A Antivirus for Linux Desktop

topicons02.jpg?version=1&modificationDat

Share this post


Link to post
Share on other sites

But it's not that much recommended to disable AppArmor/SELinux , is that right?

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...