Jump to content
bruno67

Error during install server-linux-x86_64.sh on ubuntu

Recommended Posts

Hello,

I try to install ESET Security Management Center (7.0.471.0) on an ubuntu

Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic

I made all the steps from that page :

https://help.eset.com/esmc_install/70/en-US/prerequisites_server_linux.html

I installed this mysql server

+-------------------------+-------------------------+
| Variable_name           | Value                   |
+-------------------------+-------------------------+
| innodb_version          | 5.7.25                  |
| protocol_version        | 10                      |
| slave_type_conversions  |                         |
| tls_version             | TLSv1,TLSv1.1           |
| version                 | 5.7.25-0ubuntu0.18.04.2 |
| version_comment         | (Ubuntu)                |
| version_compile_machine | x86_64                  |
| version_compile_os      | Linux                   |
+-------------------------+-------------------------+

I installed this ODBC Driver 5.3.12
I copied
libmyodbc5a.so  libmyodbc5S.so  libmyodbc5w.so to /usr/local/lib
and launched
myodbc-installer -a -d -n "MySQL ODBC 5.3.12 Driver" -t "Driver=/usr/local/lib/libmyodbc5w.so"
myodbc-installer -a -d -n "MySQL ODBC 5.3.12 Driver" -t "Driver=/usr/local/lib/libmyodbc5a.so"

my file odbcinst.ini
[MySQL ODBC 5.3.12 Driver]
Driver=/usr/local/lib/libmyodbc5a.so
UsageCount=2

When I launch the installer
./server-linux-x86_64.sh \--skip-license \--locale fr-FR \--server-root-password xxxx \--db-driver [MySQL ODBC 5.3.12 Driver] \--db-hostname 192.168.xx.xx \--db-port 3306 \--db-user-username era_db_user \--db-user-password XXX \--cert-hostname 192.168.XX.XX

I have these errors

Extracting archive, please wait...
Archive extracted to /tmp/tmp.kcfOTy9538.
Checking OpenSSL ... done [OpenSSL 1.0.2n 7 Dec 2017]
Reading previous installation settings ... failure
Checking installed version... done
Status of current installation is: NEW
Checking database connection ... failure

When I see the log in /var/log/eset/RemoteAdministrator# more EraServerInstaller.log
I have :
2019-04-15 11:31:06 Information: Installer: Initializing logging to file /var/log/eset/RemoteAdministrator/EraServerInstaller.log
2019-04-15 11:31:06 Information: Installer: Parsing arguments.
2019-04-15 11:31:06 Information: Installer: Verifing arguments.
2019-04-15 11:31:06 Information: Installer: Starting install sequence.
2019-04-15 11:31:07 Information: Installer: Extracting archive to /tmp/tmp.kcfOTy9538
2019-04-15 11:31:10 Information: Installer: Archive extracted to /tmp/tmp.kcfOTy9538.
2019-04-15 11:31:10 Information: Installer: Checking OpenSSL ...
2019-04-15 11:31:10 Information: DepCheckOpenSSL: Action invoked with:
2019-04-15 11:31:10 Information: DepCheckOpenSSL: Set output property: P_OPENSSL_VERSION = OpenSSL 1.0.2n  7 Dec 2017
2019-04-15 11:31:10 Information: DepCheckOpenSSL: Return code: 0
2019-04-15 11:31:10 Information: Installer: Found: OpenSSL 1.0.2n 7 Dec 2017
2019-04-15 11:31:10 Information: Installer: Reading previous installation settings ...
2019-04-15 11:31:10 Information: LoadInstalledData: Action invoked with:  --current-version 7.0.471.0 --db-connectors-dir /tmp/tmp.kcfOTy9538/setup --db-driver MySQL --db-h
ostname 192.168.80.180 --db-name era_db --db-port 3306 --db-type MySQL-Server --db-user-password ********** --db-user-username ********** --modules-dir /var/opt/eset/Remote
Administrator/Server/Modules/ --product-guid "" --product-name Server --startup-config-path /etc/opt/eset/RemoteAdministrator/Server/StartupConfiguration.ini
2019-04-15 11:31:10 Error: LoadInstalledData: Startup configuration file '/etc/opt/eset/RemoteAdministrator/Server/StartupConfiguration.ini' does not exist, is empty or is
not regular file
2019-04-15 11:31:10 Information: Installer: Failed reading previous installation settings.
2019-04-15 11:31:10 Information: Installer: Checking installed version...
2019-04-15 11:31:10 Information: CheckVersion: Action invoked with:  --current-version 7.0.471.0 --installed-version ""
2019-04-15 11:31:10 Information: Product is not installed
2019-04-15 11:31:10 Information: CheckVersion: Set output property: P_VERSION_STATUS = NEW
2019-04-15 11:31:10 Information: CheckVersion: Return code: 0
2019-04-15 11:31:10 Information: Installer: Checking of installed version was successful
2019-04-15 11:31:10 Information: Installer: Status of current installation is: NEW
2019-04-15 11:31:10 Information: Installer: Checking database connection ...
2019-04-15 11:31:10 Information: DbCheckConnection: Action invoked with:  --current-version 7.0.471.0 --db-admin-password ********** --db-admin-username ********** --db-con
nectors-dir /tmp/tmp.kcfOTy9538/setup --db-driver MySQL --db-hostname 192.168.XX.XX --db-name era_db --db-port 3306 --db-scripts-dir /tmp/tmp.kcfOTy9538/setup/Database/ --
db-type MySQL-Server --db-user-password ********** --db-user-username ********** --installed "" --modules-dir /var/opt/eset/RemoteAdministrator/Server/Modules/ --product-na
me Server --silent-reinstall "" --upgrade ""
2019-04-15 11:31:10 Information: DbCheckConnection: Set output property: P_DB_CONNECTION_STATUS =
2019-04-15 11:31:10 Information: DbCheckConnection: Set output property: P_DB_STATUS =
2019-04-15 11:31:10 Information: DbCheckConnection: Set output property: P_DB_UPGRADE =
2019-04-15 11:31:10 Information: DbCheckConnection: Set output property: P_DB_USE_FIRST_USER =
2019-04-15 11:31:10 Error: DbCheckConnection: No enum format of database type exists for provided user format: "MySQL-Server".
2019-04-15 11:31:10 Information: Installer: Failed checking database connection.
2019-04-15 11:31:10 Information: Installer: Error: : Error occurred while checking database connection

Someone can help me, please

Thanks

 

Edited by bruno67

Share this post


Link to post
Share on other sites

It seems that installer did not correctly parsed command line parameters and is not able to detect MySQL DB type. Even if this is correct, parameters for database drivers should be without "[" and "]", i.e. it should have been:

--db-driver="MySQL ODBC 5.3.12 Driver"

where name depends on driver name, i.e. contant of /etc/odbcinst.ini.

Also be aware that ESMC might not even install with this version of driver. There has been some change in driver behavior that ESMC is not compatible with and those issues should be resolved in upcoming ODBC driver releases. Since than, older version should be used (please consult with ESMC documentation for specifics).

Share this post


Link to post
Share on other sites

thanks for your answer , I have just tested ,but the problem is the same.

I 'm going to test with ODBC 5.3.10 but it seems to be no more present on MYSQL website

Share this post


Link to post
Share on other sites
35 minutes ago, bruno67 said:

thanks for your answer , I have just tested ,but the problem is the same.

I 'm going to test with ODBC 5.3.10 but it seems to be no more present on MYSQL website

In case it is the same error, there is still problem with parameter:

--db-type="MySQL Server"

could you verify what value is used? According to log, there is some different value.

Share this post


Link to post
Share on other sites

I remove '-' in Mysql-Server and the error is not the same , I think you found my error

thanks

Share this post


Link to post
Share on other sites

just a question I have this error:

CMysqlCodeTokenExecutor: CheckVariableInnodbLogFileSize: Server variables innodb_log_file_size*innodb_log_files_in_group value 100663296 is too low

I have:
| innodb_log_file_size        | 50331648 |
| innodb_log_files_in_group   | 2        |

and my server have 2GB of RAM

Can you say me what I have to change to remove the error

thanks

Share this post


Link to post
Share on other sites
31 minutes ago, bruno67 said:

just a question I have this error:

CMysqlCodeTokenExecutor: CheckVariableInnodbLogFileSize: Server variables innodb_log_file_size*innodb_log_files_in_group value 100663296 is too low

I have:
| innodb_log_file_size        | 50331648 |
| innodb_log_files_in_group   | 2        |

and my server have 2GB of RAM

Can you say me what I have to change to remove the error

thanks

Please check MySQL configuration requirements are described on this documentation page.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...