Jump to content
Clark T

Mozilla Firefox Secure online banking don't work.

Recommended Posts

Hello,

I use the latest Mozilla Firefox Quantum 65.0.2 (64-Bit) browser on Windows 10 Pro (64-Bit) and with the latest EIS 12.1.31.0 currently the secure online banking do not work.

I get this error message from Mozilla Firefox:

"Error: Secure connection failed

Connecting to bpp.eset.com failed. The certificate of the remote station has an invalid signature. Error code: SEC_ERROR_BAD_SIGNATURE

     The website can not be displayed because the authenticity of the data received could not be verified.
     Please contact the owner of the website to inform him of this issue."

The URL for secure online banking from EIS is: https://bpp.eset.com/de-DE/Home

 

Maybe this url is some kind blacklisted from Mozilla currently?

 

Any ideas?

Share this post


Link to post
Share on other sites

Is Firefox Quantum installed on the machine? Ie. it's not a portable version, correct?

Is the ESET root CA certificate imported in the Mozilla's trusted root CA certificate store? If so, close Firefox and any other browsers that might be running, disable SSL/TLS filtering in the advanced setup, click OK, re-enable SSL/TLS filtering and try again. Check if the ESET root CA certificate was imported alright.

Share this post


Link to post
Share on other sites
5 hours ago, Marcos said:

Is Firefox Quantum installed on the machine? Ie. it's not a portable version, correct?

Is the ESET root CA certificate imported in the Mozilla's trusted root CA certificate store? If so, close Firefox and any other browsers that might be running, disable SSL/TLS filtering in the advanced setup, click OK, re-enable SSL/TLS filtering and try again. Check if the ESET root CA certificate was imported alright.

Firefox Quantum is installed on my PC, also EIS. I made all you said and the ESET certificate looks properly installed.

The certificate has the serial number and SHA-256-Fingerprint, SHA1-Fingerprint.... looks all good.

Common Name: ESET SSL Filter CA
Organization: ESET, spol. s r. O.

validity period:
Starts with: Friday, March 15, 2019
Valid until: Monday, March 12, 2029

My wife is on the same router with her PC and use Windows 10 Home 64-bit with EIS installed, same Firefox Quantum and for her it works. I don't know what is wrong here for me, maybe the certificate is some kind broken? Any other thing I could try?

Share this post


Link to post
Share on other sites

I deinstalled EIS, than I installed the latest EIS. Now it works again. I don't know what was wrong, thanks for the help.

Share this post


Link to post
Share on other sites

Here's a FireFox posting on the error: https://support.mozilla.org/en-US/questions/1170738

Check FireFox's root CA certificate store and ensure only one Eset root CA certificate is present. If multiple ones exist, keep the one associated with Eset 12.1.31 installation and delete the rest.

Share this post


Link to post
Share on other sites

Got the same issue.

I restarted into safe mode. After that I deleted the entire folder "OPP" which was located under C:\ProgramData\ESET\ESET Security. In this folder you can find your Firefox profile that eset will use for banking protection. The profile will be recreated if banking protection is restarted.

 

You cant delete this folder when you are logged in normaly. But I didnt test to delete the profile via about:profiles because the profile that it shows seems like my normal firefox profile. the path to profile did not match with esets path. But about:support shows the correct path. Would be nice if eset could make an button in settings to delete this profile or to clean it automatically sometimes.

Share this post


Link to post
Share on other sites
3 hours ago, timse201 said:

Got the same issue.

I restarted into safe mode. After that I deleted the entire folder "OPP" which was located under C:\ProgramData\ESET\ESET Security. In this folder you can find your Firefox profile that eset will use for banking protection. The profile will be recreated if banking protection is restarted.

 

You cant delete this folder when you are logged in normaly. But I didnt test to delete the profile via about:profiles because the profile that it shows seems like my normal firefox profile. the path to profile did not match with esets path. But about:support shows the correct path. Would be nice if eset could make an button in settings to delete this profile or to clean it automatically sometimes.

This worked for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...