Jump to content

ESET Banking & Payment Protection can't work.


Recommended Posts

  • Administrators

I think the problem here is with HTTP/2 that the bank site supports. BPP is going to have HTTP/2 support added within the following couple of weeks.

Link to comment
Share on other sites

  • Administrators
3 hours ago, Purpleroses said:

I'm having the same issue with my banking site https://www.bmo.com/main/personal can't direct to secure browser. Is there any solution to this problem?

I've tried it and a secure browser opened after clicking Login -> Online Banking.

image.png

Link to comment
Share on other sites

54 minutes ago, Purpleroses said:

Other one that a friend uses https://www.cibc.com/en/personal-banking.html and it also does not open in secure browser

This site doesn't use an EV certificate which I believe is the issue. It will have to be added manually to BP&P to open automatically to BP&P from a normal browser session.

Link to comment
Share on other sites

I have added it  manually to BP&P and still opens up in a normal browser not secured.  It use to  automatically do it a long time ago but I can remember when.  Does Eset BP&P protect every banking site?  The banking and payment protection icon on my desktop can I click on that and enter the banking website address url and is that safe to do?

Edited by Purpleroses
Link to comment
Share on other sites

12 hours ago, Purpleroses said:

The banking and payment protection icon on my desktop can I click on that and enter the banking website address url and is that safe to do?

Yes.

Link to comment
Share on other sites

  • 2 weeks later...

I am also experiencing problems with ESET Banking & Payment Protection.
It has stopped automatically opening a secure browser with the green border for my bank and PayPal.
I only realized a few days ago that it had stopped working, so it seems like one of the recent updates to ESET has changed something.

I have been successfully using the ESET Banking & Payment Protection system since it was released.
When this feature was added to ESET, the banks I use were detected and automatically added to the Protected websites list (as far as I can remember).
When I realized there was a problem, I deleted all my banks from the protected websites list to see what would happen.
No banking websites are being detected now.
Both Secured Browser and Ask Me settings have stopped working.

I am manually opening a secured browser using the Tools menu, until this problem can be fixed.

My main banking website is:
https://www.stgeorge.com.au/

Version of ESET Internet Security in use: 12.1.31.0

 

Edited by morezen
Link to comment
Share on other sites

  • Administrators

The above website uses http/2 which is not currently supported by BPP. You should be able to open a secure browser manually by clicking its icon on the desktop and then open bank's website in it.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...