Jump to content

ERA 6.5 Server MySQL issue - Windows Server 2016


bNetworked
 Share

Recommended Posts

I've got a project that I've started that involves:

Migrating an ERA 6.5 server install on Ubuntu/MySQL to Windows Server 2016/MySQL, and then the Windows Server install is going to be upgraded to ESMC once complete.  I need to use MySQL on Windows apparently because I've read that the database server has to be same in order for me to be able to export it from the MySQL/Ubuntu config to the Windows Server config.

Here's what I'm trying to install:

WIndows Server 2016 x64

MySQL 5.7.22 64 bit

ODBC Connector 5.3.10

the problem that I'm running into is that no matter what I do, and what combination of software I run (I've tried different 5.7.x versions of MySQL, versions of 5.2.x and 5.3.x of the connector) I always get the error "the database server is not configured correctly."  This is apparently usually attributed to a setting in the my.ini file, but I've changed that setting and even used the command line to dump the variables (SHOW CONFIG) to verify that it has indeed taken hold with max_allowed_packet set to 33M (or more, I tried 50m just for fun and that didn't matter either).  I've gone through all the pre-requisites half a dozen times and double checked configs too.

I've been banging my head on the wall for about 5 hours now and I'm out of ideas.  I tried to search on the error in the forum here and I didn't get anything ... at the very least can someone point me to where install logs (or how to create them?) for the 64 bit ERA server install of 6.5 so that I can get some kind of detailed log of what is going wrong?  Or does anyone have a good suggestion on how to resolve this?

 

thanks,

 

Brian

Link to comment
Share on other sites

  • ESET Staff

Just to be sure, there are two other settings of MySQL server that has to be changed:

innodb_log_file_size=100M
innodb_log_files_in_group=2

Could you verify those too? They can have different values but there are minimal requirements that are larged than default (documentation).

Link to comment
Share on other sites

Martin - 

Thanks.  This cleared up my problem.  Apparently I'd just been working on that too long yesterday and I saw the part where it said MySQL 5.6.22 and missed the two important words that - "and later."

FYI - the innodb_log_files_in_group setting is not present in the my.ini file for the 5.7.x MySQL that I had installed.  I think that the default setting of 2 may be implied, but I just added the settings variable to the my.ini file just to be sure.

Thanks for your help on this ... it just needed to be looked at by someone else that hadn't been banging their head on the wall all day long.

Cheers,

Brian

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...