Jump to content

Can't use AD integration


Dzemboc77
 Share

Recommended Posts

Just completed a migration to 7 from version 6.5, for some reason I can't log in with my domain credentials. I joined it back to the domain, If I go to mapped domain security groups, I deleted my old one created a new 1 and can select the security group. However after adding it the Domain users is blank.  What am I missing ???

 

image.thumb.png.883c1ffc9a53a1402e8155f9fac5905d.png

Link to comment
Share on other sites

Also my AD sync job is failing with SearchLDAP kinit failed with 1 stdout password for X.X.com

stderrL Kinit KDC reply did not match expectations while getting initial credentials.

Link to comment
Share on other sites

  • ESET Staff

Domain users will be populated as soon as your users login. It is not showing the one "Entitled" from the group, but the ones that have actually logged in at once.

With regards to the AD Sync Job, I can´t comment.

Link to comment
Share on other sites

I have permissions but I can't login, Just get the pop up message " Login failed"  I can change username and enter random passwords and its the same error. Its like its not authenticating properly. 

Link to comment
Share on other sites

  • ESET Staff

Could you please check SERVER's trace.log for "Error:" entries from time that login does not works? When did this started to happen? Are you using "\" delimiter when specifying domain name in login screen or some alternative?

Link to comment
Share on other sites

For my part, it looks to be a memory allocation error : 

2019-02-01 12:36:02 Error: ConsoleApiModule [Thread 7f9026fdd700]: 142 Error while sending AuthenticateUser request [UserName=DOMAIN\user] boost::process::detail::posix_start: fork(2) failed: Cannot allocate memory
2019-02-01 12:36:02 Error: ConsoleApiModule [Thread 7f9026fdd700]: Untranslatable CInterModuleException: boost::process::detail::posix_start: fork(2) failed: Cannot allocate memory
2019-02-01 12:36:02 Error: CServerSecurityModule [Thread 7f90b77fe700]: boost::process::detail::posix_start: fork(2) failed: Cannot allocate memory

 

The ova image was configured with 4 GB of ram, I ended up boosting it to 10 GB because of errors I first got when I tried to migrate from ERA 6.5 to ESMC 7.

I am monitoring the virtual machine's memory usage right now and I can see that its using 7.56GB of memory.

Maybe a JVM setting I missed?

 

Link to comment
Share on other sites

On 1/28/2019 at 11:36 AM, Craig.Dzembo said:

I have permissions but I can't login, Just get the pop up message " Login failed"  I can change username and enter random passwords and its the same error. Its like its not authenticating properly. 

This! I can define a Mapped AD group to admin permission set, but when I try and login I get "Login Failed"

I am using DOMAIN\username

if I use a bad password or username on purpose the error is still "login failed"

How can I go about troubleshooting this?

Complete ESET SMC newb here, so be gentle hahaha

 

TIA

Link to comment
Share on other sites

21 hours ago, AuMonroe said:

This! I can define a Mapped AD group to admin permission set, but when I try and login I get "Login Failed"

I am using DOMAIN\username

if I use a bad password or username on purpose the error is still "login failed"

How can I go about troubleshooting this?

Complete ESET SMC newb here, so be gentle hahaha

 

TIA

AuMonroe, if your ESMC server is a virtual appliance, you need access to the server's terminal

  1. Open the virtual appliance console (from your hypervisor), login with the administrator's password
  2. Then you can either
    • Enable remote access : this will give you the option to SSH into your ESMC server
    • Exit to terminal
  3. Browse to the /var/log/eset/RemoteAdministrator/Server/ folder. The trace.log file should be there.

Dont forget to disable the remote access if you enabled it

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...