Jump to content

[SOLVED] Client Tasks - Invoke ASAP If Event Missed doesn't work as expected


Nono
 Share

Recommended Posts

I've currently an issue with a Client task which aren't execute on computer not restarted for few days.

What I want to achieve: Execute a Batch script every week day at 10AM on our endpoints and execute ASAP the script if the endpoint wasn't reachable/on at 10AM.

My issue: Endpoint which aren't restart doesn't get the batch script executed.

How I setup (probably wrongly?) the task :

image.thumb.png.31a3a50694dc29f9f64cf647fc104a5c.png  

 

 

image.png.0d71b5173f55b913f2641fce3c7b642b.png

This seems to NOT work when the computer goes in hibernation/sleep mode. (no matter if the computer is on at 10 AM, or later).

 

Would this be a bug or an configuration issue ?

 

Many thanks for your help !

Edited by Nono
Link to comment
Share on other sites

  • ESET Staff

Could you please provide version of AGENT installed on those machines? Is it latest available version? Asking because we had a bug in first 7.0 release with the same symptoms. Issue was triggered by time shift (time synchronization), which is normal for long running system, and only way to recover from it was to reboost (= restart AGENT service). This issue has been resolved in AGENTs distributed with release 7.0.72.0 (November 2018).

Link to comment
Share on other sites

  • ESET Staff
1 hour ago, Nono said:

It's actually a mix of two :

7.0.2073.0 & 7.0.2073.1

 

is 7.0.2073 > 7.0.72 ?

This seems to be more version of ESET Endpoint Security, but we will need version of "ESET Management Agent" installed on client machines.

Link to comment
Share on other sites

  • ESET Staff
35 minutes ago, Nono said:

Oh, my bad.

It's then 7.0.553.0 for everyone

 

Thanks for confirmation -> you are indeed using AGENT from original ESMC release that contained this issue, which has been resolved in subsequent service release, where ESET Management Agent for Windows has version 7.0.577.0. I would recommend to try to update AGENT on affected system manually and monitor behavior. Update should not require reboot, so it should be possible even on server-based system. Also it is not required to upgrade any other part of ESMC infrastructure, it not already on latest versions.

Link to comment
Share on other sites

I tried to install it (this one : https://download.eset.com/com/eset/apps/business/era/agent/latest/agent_x64.msi )

but got :

image.png.6b3281c06c0b6b6e84d7e6fbabeb4d3b.png

I can send you the install log (via private message only), but it doesn't contain the IP of my ESMC server (even though I ticked 'keep the current info' during the installation).

Link to comment
Share on other sites

@MartinK I usually use the "ESMCAgentInstaller.bat" to install the agent on my endpoint.

By editing the script, I've notice this part :

set url=hxxp://repository.eset.com/xxx/v7/7.0.553.0/agent_x64.msi
set checksum=yyyyyy
if defined IsArch_x86 (
  set url=hxxp://repository.eset.com/xxx/v7/7.0.553.0/agent_x86.msi
  set checksum=yyyyy
)

if you could provide me the url + checksum for the version 7.0.577.0 I could probably reuse the script with the credentials/cert/IP I already have, isn't it ?

Link to comment
Share on other sites

  • 2 weeks later...

It turns out that I still had the "prerelease" link as repository server (due to early access ESMC)

Change it to "AUTOSELECT" on Server settings + Agent Policy settings, show me that I should be able to update my version which should solve the issue.

I've currently an issue to update both client + agent remotely (aka from ESMC), but I guess I'll have to contact my ESET Representative for that.

Current behavior : Updating remotely remove the AGENT, and leave (only) the client out-dated.

Link to comment
Share on other sites

  • 1 month later...

I'm just adding a conclusion to that particular issue.

So indeed, the original issue was caused by the agent version and the new version solve the issue (tasks are executed ASAP).

 

Concerning my 2nd issue, in order to upgrade my client + agent I have to :

1) Use the ESET Uninstaller tool (and remove everything)

2) Install the new agent

3) Install the new client

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...