Jump to content

[Major Bug] ESET Firewall dissappearing


Recommended Posts

There is a major bug in the latest version of ESET v7.0.203.26. I block some connections and every so often it causes processes to freeze in the task manager and I cannot kill the process. Only when i do a Force Log OFF, i see the missing Notice from the firewall appear suddenly, then dissapear. I disabled Web and Email protection, and it still does it. I disabled Anti-Stealth Protection and it still does it. Any way I can debug whats going on?

 

System:

Windows 7 x64 - All updates installed - Also clean install

12 GIG of RAM

Memtest done - Nothing found

 

Anyway I can help , let me know.

 

PS: also, the icon gives me a flashing error icon near the taskbar, and it happens whenever I block certain connections.. and it starts to make the computer freeze.

Edited by jefrotone
Link to comment
Share on other sites

Hello jefrotone,

 

Would you kindly be more specific to which programs, apps, connections, that you are blocking ?

Possibly provide some screen shots of what you are blocking and the method used to better understand the scenario you are experiencing.

Also what mode is your firewall currently in.

 

Procmon is probably the best utility to tell what is going on. :)

Link to comment
Share on other sites

Hi.

 

I just registered an account because i was once again searching for problems/solutions like mine and i finally found someone with a similar problem (i would say it's the same bug).

 

It happens to me exactly the same as jefrotone, but i can give further informations about it since i already tested many ways to solve it.

 

 

First of all, i'm using Eset Smart Security 7.0.302.26, Windows 7 x64 and the firewall is on interactive mode. What really happens is that sometimes the popup window of allow/deny an app from acessing the web doesn't appear at all and because of this, every new app that starts and doesn't have a rule (window should appear), will freeze and won't be possible to terminate that process in task manager.

 

So, let's try an example:

I open my new application called aaa.exe and it tries to access the web, but the firewall prompt bugs out and it doesn't appear asking me to allow or deny such access. Basically, it's the same as having the popup without clicking any action, the aaa.exe will be blocked (since is waiting to access internet, others apps may time out and keep running) and every new application that i start after that requires me to allow or deny access, will be blocked too. So what happens is i am going to have aaa.exe, bbb.exe, ccc.exe in task manager and it's impossible to terminate them, simply there's no way.

The solution for this, is to reboot system (or logoff) and as soon as all icons disappear from desktop, the popup window appear for like 1 second and then Windows shuts.

 

Another temporary way to keep lettings applications access the web without restart, is switching the firewall to automatic mode which lets the applications to access the web (but keeps the "old" ones blocked) and going back to interactive mode doesn't "unbug" the bug.

 

I'm used to Eset for many years already (oh, the good old Nod32...) and since version 2/3/4 that i'm using the firewall in interactive mode and it always worked well except now on version 7. So, basically, this is a little annoying bug that when happens, it can crack someone's head, but far away from making me move from such good protection software.

 

I hope i was clear enough with my english explaining the problem and i'll keep an eye here for updates. :)

Edited by Trollitito
Link to comment
Share on other sites

  • Administrators

I reckon it was mentioned in another thread that intermittent issues with the interactive dialog window not showing up would be addressed in the next v7 build.

Link to comment
Share on other sites

That's good to know. I tried to find identical problems on google but ended up finding related to other stuff, so i thought it could be something on my computer.

 

Glad to know you're aware of it and it'll be fixed in the future. :)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...