Jump to content
cutting_edgetech

Eset Internet Security 12.0.31.0 Network Connections Viewer Bug

Recommended Posts

There seems to be a bug with Network Connections Viewer in Eset Internet Security 12.0.31.0. I'm running a P2P Client called Fopnu right now, and downloading a file. Fopnu Client is not showing up in the Network Connections Viewer.  It shows nothing actively downloading at all. I clicked on refresh several times and there was no change. I exited out of Network Connections Viewer, and then opened it again but no change.

I'm using Windows 10 x64 Pro version 1709.

Network Connection Viewer.jpg

Share this post


Link to post
Share on other sites
1 hour ago, cutting_edgetech said:

I'm running a P2P Client called Fopnu right now, and downloading a file. Fopnu Client is not showing up in the Network Connections Viewer.

If its using UDP, the Eset network connections feature will not show the connection. It only shows TCP connections similar to many network activity monitors such as TCPView.

Share this post


Link to post
Share on other sites

Ok, thank you for providing me with that info! I must say i'm disappointed. I think they should also monitor UDP as well. I will just rely on Process Hacker, and others that monitor other protocols.

Share this post


Link to post
Share on other sites
On 12/23/2018 at 3:43 PM, itman said:

It only shows TCP connections similar to many network activity monitors such as TCPView.

That TCPView only shows TCP connections is logical if you look at the name.

 

14 hours ago, cutting_edgetech said:

I think they should also monitor UDP as well.

I agree. The EIS tool is called "Network connections". That name suggests that all network connections are shown.

Share this post


Link to post
Share on other sites

If you want to monitor all UDP connections, use something like Nirsoft's LiveTcpUdp network monitor.

Share this post


Link to post
Share on other sites

True, I can use Nirsoft's tool, I have in the past, but Eset should improve their Network Connections viewer. I think it falls short of expectations.

Share this post


Link to post
Share on other sites

Hello @cutting_edgetech,

While you are on the "Network connections" tab in the ESET GUI, right click in the "Network connections" pane and uncheck "Show only TCP connections". UDP connections should now show along with the TCP connections.

I hope this helps...

Share this post


Link to post
Share on other sites
31 minutes ago, puff-m-d said:

While you are on the "Network connections" tab in the ESET GUI, right click in the "Network connections" pane and uncheck "Show only TCP connections". UDP connections should now show along with the TCP connections.

Good catch. I didn't know that option existed.

Also the only way I could enable this is to right click on a shown existing connection and set off the TCP only option there. Thereafter, it applied to all shown connections.

Share this post


Link to post
Share on other sites

@puff-m-d: Thanks for the advice!

So the tool is better than expected. Thanks ESET. However, why is the default to show only TCP connections? Why give the impression that you can barely crawl if you are able to run?

Share this post


Link to post
Share on other sites
4 hours ago, puff-m-d said:

Hello @cutting_edgetech,

While you are on the "Network connections" tab in the ESET GUI, right click in the "Network connections" pane and uncheck "Show only TCP connections". UDP connections should now show along with the TCP connections.

I hope this helps...

Thank you! I did not know that option was there! Eset should not hide this option. It causes people to waste a lot of their time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×