Jump to content

Subfolders not working as I want

Guest sindbad

Recommended Posts

Guest sindbad

Hi all,


The subfolders are not working like I thought. Please advice me. 

I have the following:

Company A computer - folder

Company A servers - subfolder


when clicking company A - folder. I also see the servers? I thought that when you move the computers/servers from folder to subfolder. It gets moved. Right now it looks like it gets copied? 


I have applied a policy on company A - computers. 

I have applied a policy on company A - servers. 

What is happening now? Company A - computers is getting policy applied on the computers + servers. Because the servers are still in the main folder. 


Why is it like that? Is there a benefit from it? Because I dont see it. 


Right now I have to make a new folder. 

 Company A computers - folder

Company A servers - folder

when applying policy on above, it will split it like it should. 

Link to comment
Share on other sites

  • Administrators

Policies assigned to parent groups are also applied to child groups. If you want to avoid that, move the subgroup to a separate group or create a new group without any policies assigned and move both the computers and servers group into it.

Link to comment
Share on other sites

  • ESET Staff


You can disable the behavior by unchecking the "show subgroups" checkbox. Of course they are placed in the correct group, but if group B is a subfolder of group A, and you click on group A with "show subgroups" enabled, you will see them there. Also, policy product is different for Workstations (Endpoint Security for Windows) and Servers (File Security for Windows servers) so settings would cross-apply only for the management agent.

Link to comment
Share on other sites

Guest sindbad

I have changed it like @Marcos suggested. 

Now I have:

company a clients

company a servers

company b clients

company b servers


@MichalJ you are right. If I check the applied policies, I do see that they do not do any harm. Because they are greyed out. Server does not touch workstation policy and vice versa. Good to know. 


But having it in seperate groups. Is easier for me. 


You can close this topic. It’s solved. I hope that other people that are searching for this answer, will understand it as well. 

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...