Jump to content

ESET ESMC Agent not installing


Recommended Posts

Dear All

We tried installing ESET ESMC Agent for a customer on three windows 8 desktop computers, but met with the error below during installation 

Service ‘ESET Management Agent’(EraAgentSvc)failed to start.

Verify that you have sufficient privileges to start system services



  • We tried installing using admin account with the highest privilege but still encounters the same error stated above  


Kindly Note

Installation of ESMC Agent on laptop computers and servers were successful 


Looking forward to your response 


P.s  Please find the system log for your perusal  





Link to comment
Share on other sites

  • 4 weeks later...

Sorry but I don't have a solution but I dread every time I have to update an agent on a PC as 90% of the time it fails with this exact issue. No matter the version of the agent v6 through to v6.6, if on domain, work group, under local admin account, etc. All have problems. Even when I call their support they don't know how to fix it, other than to use the uninstall tool in safe mode.

We gave up trying in the end as with 1500 clients it caused too much work and now users only get the latest agent when their PC gets replaced.


I have no idea why these companies make it so difficult to use their products! 

Link to comment
Share on other sites

  • 1 month later...
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...