Jump to content

Agent 'No connection attempt accurred' warning


Karl
 Share

Recommended Posts

Setup

ESET Remote Administrator (Server), Version 6.5 (6.5.417.0)
ESET Remote Administrator Agent 6.5.417.0 (for Linux)

Hi,

I successfully installed the agent on my Ubuntu 18.04 client machine. The agent also successfully connects to the ERA Server and shows up in the server's Dashboard.

After one minute, I see a warning for my client in the server's Dashboard: 'Product is not connected. No connection attempt occurred.'

However, my client agent's log states that the connection to the server is working (every minute):

Information: CReplicationModule [Thread 7f32a2ffd700]: CReplicationManager: Success of scenario (type=Regular, task_id='<hidden>', link='Automatic replication (REGULAR)' (<hidden>), remote_peer=host: "<hidden>" port: <hidden>, remote_peer_type=3, remote_peer_id=<hidden>, remote_realm_id=<hidden>)
2018-11-10 15:33:26 Information: CReplicationModule [Thread 7f32a2ffd700]: CReplicationManager: Closing network connection

On the server I see an error every minute in the server logs, but I couldn't find anything online about that error code:

2018-11-10 16:02:22 Error: NetworkModule [Thread 7f4e4effd700]: Error code:104;Connection reset by peer; SessionId:81
2018-11-10 16:03:26 Error: NetworkModule [Thread 7f4e4f7fe700]: Error code:104;Connection reset by peer; SessionId:86
2018-11-10 16:04:26 Error: NetworkModule [Thread 7f4e4effd700]: Error code:104;Connection reset by peer; SessionId:89

 

When I restart the agent (service eraagent restart), then for one minute the warning in my server dashboard disappears. It seems to me, that the agent is not able to handle subsequent calls to the server. Only the first call to the server seems to work. However, the logs state every minute that the connection to the server was successful, so I am a little lost here. Any idea on that one?

 

Thank you!

Edited by Karl
Link to comment
Share on other sites

  • ESET Staff

It might be little confusing, but error:

Product is not connected. No connection attempt occurred.

actually means that ESET Security product (UEABVE or UESETS?) installed on this particular client device is not communicating with AGENT. By default, product should contact AGENT every minute, so In case this warning persists for a longer time, I would recommend to check whether installed product is actually running.

Link to comment
Share on other sites

Ah interesting. Thank you for the fast response!

I have ESET NOD32 AntiVirus 4.0.90.0 running on my Ubuntu 18.04 client. Verified that the product is actively running:
 

$ uname -a
Linux client 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
$ sudo service esets status
● esets.service - ESET NOD32 Antivirus
   Loaded: loaded (/lib/systemd/system/esets.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-11-11 03:01:49 CET; 32min ago
  Process: 1202 ExecStart=/opt/eset/esets/sbin/esets_daemon (code=exited, status=0/SUCCESS)
 Main PID: 1720 (esets_daemon)
    Tasks: 11 (limit: 4915)
   CGroup: /system.slice/esets.service
           ├─1720 /opt/eset/esets/sbin/esets_daemon
           ├─7565 /opt/eset/esets/sbin/esets_daemon
           └─7567 /opt/eset/esets/lib/esets_mac

Nov 11 03:01:46 client systemd[1]: Starting ESET NOD32 Antivirus...
Nov 11 03:01:49 client systemd[1]: Started ESET NOD32 Antivirus.
Nov 11 03:01:49 client esets_mac[1722]: error[06ba0000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:02:10 client esets_mac[2233]: error[08b90000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:07:02 client esets_mac[5641]: error[16090000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:12:03 client esets_mac[5810]: error[16b20000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:13:41 client esets_mac[6103]: error[17d70000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:18:41 client esets_mac[7081]: error[1ba90000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:23:42 client esets_mac[7361]: error[1cc10000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)
Nov 11 03:28:43 client esets_mac[7567]: error[1d8f0000]: Cannot unblock removable media (org.freedesktop.udisks2.filesystem-mount)

Sadly, I am still seeing the 'Product is not connected. No connection attempt occurred.' warning. I dont see any reason why ESET NOD32 AntiVirus is not connecting with my local agent. Are the error messages 'Cannot unblock removable media' reasonable? I am running on Ubuntu18.04, so is it alright that esets_mac is executed? Also I see this at eraagent start in the logs:

2018-11-11 02:41:38 Information: ERAG1ClientConnector [Thread 7ff0eeffd700]: Connecting to product
2018-11-11 02:41:38 Information: ERAG1ClientConnector [Thread 7ff0eeffd700]: <MODULES> Loading modules..
2018-11-11 02:41:38 Information: ERAG1ClientConnector [Thread 7ff0eeffd700]: <MODULES> Unable to load module (Loader)6002, from path: '/var/opt/eset/esets/lib/'
2018-11-11 02:41:38 Information: ERAG1ClientConnector [Thread 7ff0eeffd700]: <MODULES> Unable to load module (Loader)6002, from path: '/var/lib/esets/'
2018-11-11 02:41:38 Information: ERAG1ClientConnector [Thread 7ff0eeffd700]: <MODULES> Unable to load module (Loader)6002, from path: '/var/opt/esets/lib/'

Are some libraries missing in my case?

 

UPDATE:

I have to run the business version. I de-installed the NOD32 AntiVir version via ERA Server -> then the warning vanished. I then triggered a task to deploy the business AntiVir version on my client. It worked - no more warnings.

Thank you!

Edited by Karl
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...