Jump to content

ESET 12 does not update automatically at computer startup


Recommended Posts

I am using Windows 10 version 1803. I have recently upgraded Internet Security from version 11 to the latest version 12. I did the upgrade after ESET Internet Security notified me there was a new version available and it installed fine.

Ever since this upgrade however at system start up ESET does not automatically update anymore. Updating the definition databases manually however still works, and so do the automatic hourly updates.

I was wondering what could cause this behaviour? I don't mind manually updating after my computer boots up but this feature did work normally when I still ran version 11.

Is there a setting I missed? Is this intended behaviour? Can someone steer me in the right direction maybe?

Link to comment
Share on other sites

  • ESET Insiders
18 minutes ago, metalalbert said:

I am using Windows 10 version 1803. I have recently upgraded Internet Security from version 11 to the latest version 12. I did the upgrade after ESET Internet Security notified me there was a new version available and it installed fine.

Ever since this upgrade however at system start up ESET does not automatically update anymore. Updating the definition databases manually however still works, and so do the automatic hourly updates.

I was wondering what could cause this behaviour? I don't mind manually updating after my computer boots up but this feature did work normally when I still ran version 11.

Is there a setting I missed? Is this intended behaviour? Can someone steer me in the right direction maybe?

As you wrote automatic update of modules and data bases done every hour so this is normal and everything is working fine. I didn't understand you on what version of EIS are you now?

Link to comment
Share on other sites

I am using ESET Internet Security 12.0.27.0, the latest version I believe.

Yes everything is working fine. I only want to know why each time I start up my computer ESET does not automatically update anymore. It used to do so when I still ran the latest version of ESET Internet Security 11.

To give you even a better understanding of what my issue is, when I am not using my computer I always have it switched off. I usually only boot it up once a day and shut it off at the end of the same day. With version 11 each time I booted up my computer again, after I had it switched off the day before, ESET would automatically update the virus definitions at system start. Now with version 12 it does not.

I am merely trying to determine how that came about. It used to work but not anymore.

Link to comment
Share on other sites

1 hour ago, metalalbert said:

I am using ESET Internet Security 12.0.27.0, the latest version I believe.

Yes everything is working fine. I only want to know why each time I start up my computer ESET does not automatically update anymore. It used to do so when I still ran the latest version of ESET Internet Security 11.

To give you even a better understanding of what my issue is, when I am not using my computer I always have it switched off. I usually only boot it up once a day and shut it off at the end of the same day. With version 11 each time I booted up my computer again, after I had it switched off the day before, ESET would automatically update the virus definitions at system start. Now with version 12 it does not.

I am merely trying to determine how that came about. It used to work but not anymore.

That is the same situation I am having (maybe I could have been clearer in my previous post) see https://forum.eset.com/topic/17331-updates-download/?do=findComment&comment=86018

It used to update once I connected to the internet, now it doesn't. (I do not start up connected or stay connected to the net). Now, it does seen to try to update prior to me connecting.

What I just did was to change the the update setting (see below). Maybe this will help (I do not have a dial up connection, but did not see another connection choice in creating a new task).

We shall see.:unsure:

2021749292_Logonupdate.thumb.jpg.9ce934e7b4d7d809a27db54832ac8698.jpg

Regards,

Tom

Edited by TomFace
Link to comment
Share on other sites

11 minutes ago, TomFace said:

What I just did was to change the the update setting (see below). Maybe this will help (I do not have a dial up connection, but did not see another connection choice in creating a new task).

I believe that option only applies to a dial-up connection. That is why it is disabled by default.

The Eset task that controls updating at boot time is "Automatic update after user logon."

Link to comment
Share on other sites

29 minutes ago, itman said:

I believe that option only applies to a dial-up connection. That is why it is disabled by default.

The Eset task that controls updating at boot time is "Automatic update after user logon."

We shall see...when I log on to my machine, as I stated, I am not connected to the net. So the user logon does not help me. Granted, it won't be the end of the world if it updates an hour later, but something has changed. :unsure:

Regards,

Tom

Link to comment
Share on other sites

1 hour ago, TomFace said:

That is the same situation I am having (maybe I could have been clearer in my previous post) see https://forum.eset.com/topic/17331-updates-download/?do=findComment&comment=86018

It used to update once I connected to the internet, now it doesn't. (I do not start up connected or stay connected to the net). Now, it does seen to try to update prior to me connecting.

What I just did was to change the the update setting (see below). Maybe this will help (I do not have a dial up connection, but did not see another connection choice in creating a new task).

We shall see.:unsure:

2021749292_Logonupdate.thumb.jpg.9ce934e7b4d7d809a27db54832ac8698.jpg

Regards,

Tom

Thank you Tom. So it's not me going crazy then :)

I just checked the settings and to my surprise the one you highlighted was enabled for me. The other one, "Automatic update after user logon", was disabled.

I guess I'll switch the latter one on to see if that changes things.

UPDATE: switching that option on indeed triggered a update check at startup.

Edited by metalalbert
Link to comment
Share on other sites

Well changing the task to the logon/dial up setting did not make any changes:(.

So I guess I'll just keep an eye on it and maybe tinker a bit with it.

Regards,

Tom

Link to comment
Share on other sites

18 hours ago, TomFace said:

Well changing the task to the logon/dial up setting did not make any changes:(.

So I guess I'll just keep an eye on it and maybe tinker a bit with it.

Regards,

Tom

Good luck finding a fix :)

Link to comment
Share on other sites

19 hours ago, TomFace said:

Well changing the task to the logon/dial up setting did not make any changes:(.

Short of Eset adding a trigger event to the Scheduler to detect establishment of a broadband network connection which I honestly don't believe is going to happen, what you could do is the following. Once you establish your broadband network connection after boot time, logoff and then logon on again to Windows. This should trigger the existing Eset scheduler rule to check for updates at logon time.

Edited by itman
Link to comment
Share on other sites

1 hour ago, itman said:

Short of Eset adding a trigger event to the Scheduler to detect establishment of a broadband network connection which I honestly don't believe is going to happen, what you could do is the following. Once you establish your broadband network connection after boot time, logoff and then logon on again to Windows. This should trigger the existing Eset scheduler rule to check for updates at logon time.

I appreciate the suggestion itman, but that's too much work (after all, I've been retired for quite sometime:P). I can always do a manual update check if the auto update hasn't happened (as of yet). Like I said, it's not the end of the world.

Regards,

Tom

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...