Jump to content

Paypal still not redirecting in Online-Baning App


Recommended Posts

Hello,

when I'm adding paypal to the protected sides, it's still not redirecting to the Online-Baning App.

The bug is very old, since year .... I wrote every year a support ticket without a working solution.

I using version 12, with Win10 and Win7 at 5 different machines.

My settings:

Unbenannt.jpg.63e77b03c021ad39a9958542f7e10380.jpg

 

same problem like here:

 

 

Link to comment
Share on other sites

What browser are you using? When using IE11 (Win 7), PayPal redirects me to ESET BPP window. It does not do so when using FireFox.

But I have had issues using ESET BPP w/FireFox in the past.

Regards,

Tom

Edited by TomFace
Link to comment
Share on other sites

I using Firefox as default browser everywhere. And x64 systems.

All other banking sides (which I tried) are working ...

 

@Marcos: I don't understand what you are meaning?

Edited by Crys
Link to comment
Share on other sites

I tried paypal.com using IE11 on Win 10 x(64) 1803 in Eset ver. 11 and it wouldn't open in BP&P.

I just tried again in Eset ver. 12 and it still wouldn't open in BP&P. I tried all the following manually entered BP&P URLs with no success:

  • paypal.com
  • www.paypal.com
  • https://www.paypal.com

And, Eset .dlls are being injected. Like the OP, this appears to be the only web site with an issue. My banking web site and other manually created URLs I entered into BP&P work fine.

Edited by itman
Link to comment
Share on other sites

@Marcos: When I start the tool then I see 5 firefox.exe, but only one window with one tab is open.

When I click there at "firefox.exe" then I can see at each file the "eplgFirefox.dll" but only at one of them the "eOppMonitor.dll".

 

Why is only paypal not working but all other sides?

Link to comment
Share on other sites

I finally succeeded in getting paypal.com to open in BP&P from IE11.

@Crys, do the following:

1. In BP&P, set the www.paypal.com entry to "Ask me."

2. In FireFox, enter www.paypal.com. BP&P should open in ask mode.

3. Leave the default setting of always allowing www.paypal.com to open in BP&P as is.

4. Press the Allow option in BP&P to navigate to www.paypal.com.

Thereafter, entry of www.paypal.com in the browser should always open in BP&P mode.

Go figure why this works?

Edited by itman
Link to comment
Share on other sites

  • Administrators

Paypal.com uses http/2 so it's necessary to use the appropriate Internet protection module that supports it. Will try to test it as time allows.

Link to comment
Share on other sites

7 hours ago, itman said:

I [...]

2. In FireFox, enter www.paypal.com. BP&P should open in ask mode.

[...]

Thank you, but here it don't open in 'ask mode'.

I using the exactly same version like itman, But with Firefox ...

Link to comment
Share on other sites

8 hours ago, Crys said:

Thank you, but here it don't open in 'ask mode'.

First, verify that paypal.com is actually set to ask mode in BP&P.

HTTP/2 requires TLS 1.1 minimum support. I assume that is enabled by default in Firefox but should be verified.

Ref.: https://www.ghacks.net/2014/02/08/enable-http-2-0-firefox/

Also as I recollect from previous postings, I believe Eset has issues with HTTP/2 in Firefox. This might be why my operational "hack" doesn't work there.

Edited by itman
Link to comment
Share on other sites

Unbenannt2.jpg.30b6ac149c989b83c9dccbb4a088ee8c.jpg

Yes, I added paypal to BP&P. (If I want to add " https://www.paypal.com" it disappears, after clicking on OK.

I use Firefox v62, there HTTP/2 is enabled by default. But you can check (https://tools.keycdn.com/http2-test), that paypal don't use HTTP/2.

 

I don't think that it's a issue of encryption:

Unbenannt.PNG.8c62fbcaafab942277dfc90fd42ae373.PNG

The upper window is from an other bank (with better encrytion) which works and the lower from paypal.

 

Edited by Crys
Link to comment
Share on other sites

  • Administrators

To make it work, disable the following option in the SSL/TLS setup so that all secure communication is filtered:

image.png

In that case, HTTP/2 will be downgraded to HTTP 1.x and BPP will be able to redirect you to a secure browser.

Link to comment
Share on other sites

On 10/25/2018 at 9:04 AM, itman said:

Also as I recollect from previous postings, I believe Eset has issues with HTTP/2 in Firefox. This might be why my operational "hack" doesn't work there.

 

=======================================

EDIT:  SSL/TLS  UN-Chk  that Marcos posted above (and I missed seeing) SOLVED the issue.

 



Edited by COStark26
clarify/add info
Link to comment
Share on other sites

1 hour ago, Crys said:

But you can check (https://tools.keycdn.com/http2-test), that paypal don't use HTTP/2.

Paypal is indeed http/2:

Eset_Paypal.thumb.png.7a229e6bebc85497eca5890182b8bb68.png

Now this test was performed using IE11. Since it showed otherwise for you in Firefox, this leads me to believe the issue is FireFox and Eset together.

Edited by itman
Link to comment
Share on other sites

On 10/29/2018 at 8:03 AM, itman said:

Paypal is indeed http/2:

Eset_Paypal.thumb.png.7a229e6bebc85497eca5890182b8bb68.png

Now this test was performed using IE11. Since it showed otherwise for you in Firefox, this leads me to believe the issue is FireFox and Eset together.

 

------------------ EDIT: SSL/TLS Un-Chk Marcos posted SOLVED the issue for me. Post deleted   ------------------

 

 

Edited by COStark26
Link to comment
Share on other sites

On 10/29/2018 at 7:38 AM, Marcos said:

To make it work, disable the following option in the SSL/TLS setup so that all secure communication is filtered:

image.png

In that case, HTTP/2 will be downgraded to HTTP 1.x and BPP will be able to redirect you to a secure browser.

THIS for me is THE SOLUTION. BPP NOW Opens in FF 63.         

I hope I missed this while editing but I'll get an eye check soon. Many Thanks!!

Edited by COStark26
Link to comment
Share on other sites

  • ESET Insiders
1 hour ago, galaxy said:

Unfortunately, this does not matter to me, no matter how I try to do it with PayPal

If you really need redirection to work for Firefox 63, you could go into about:config and toggle the preference network.http.spdy.enabled.http2 to false. I'd only recommend this as a last resort.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...