Jump to content

ERA Agent 6.4 configuration issues


Andy D
 Share

Recommended Posts

Hi, 

I have a site that deploy a silent ERA agent install as part of a MDT image build. And this has worked well.

However, it would seem that someone restored a old ini file and about 80+ clients are now pointing at a old ERA server that no longer exists and uses certs that that are not trusted. 

I have tried to use our working ERA server to reinstall the agent using a server task. But it seems that it deploys, but the agents are not showing up. 

Is there a way of updating the configuration to point at the correct ERA server without having to do anything drastic here?

And will a server agent push update the agents configurations? 

Or can I take the base64 certs from the install_config.ini and build a new ERA server with that CA and get the clients to trust then have a policy on the new server that points them at the correct ERA server? 

Does anyone have a solution that may help? I seriously do NOT want to walk to each machine and change the agent. 

Regards,

Andy

Old Engineer. 

Edited by Andy D
Link to comment
Share on other sites

  • ESET Staff

What is version of your ERA Server and version of AGENT you tried to "repair"? Asking, because in case AGENTs used older version, re-execution of remote deployment task would only upgrade them without changing configuration. If this is the case, repeated remote deployment on client were AGENT has been upgrade should fix configuration.

Link to comment
Share on other sites

2 minutes ago, MartinK said:

What is version of your ERA Server and version of AGENT you tried to "repair"? Asking, because in case AGENTs used older version, re-execution of remote deployment task would only upgrade them without changing configuration. If this is the case, repeated remote deployment on client were AGENT has been upgrade should fix configuration.

HI Martin, 

We have 6.5 ERA Server and the agent is 6.4. 

To understand this correct, I just need to keep reinstalling from ERA server and agent will get new configuration? 

 

Link to comment
Share on other sites

  • ESET Staff
1 hour ago, Andy D said:

To understand this correct, I just need to keep reinstalling from ERA server and agent will get new configuration?

Yes, If I am correct, you need to run "Remote install task" on those clients 2 times. First attempt will upgrade AGENT to 6.5, second push should "repair" it with new configuration. I would recommend to check one of clients that you already pushed AGENT and verify it is upgraded to 6.5.

Edited by MartinK
Link to comment
Share on other sites

1 hour ago, MartinK said:

Yes, If I am correct, you need to run "Remote install task" on those clients 2 times. First attempt will upgrade AGENT to 6.5, second push should "repair" it with new configuration. I would recommend to check one of clients that you already pushed AGENT and verify it is upgraded to 6.5.

Hi martin, 

Yes that works!! Thank you!

Link to comment
Share on other sites

  • ESET Staff
7 hours ago, Andy D said:

Hi martin, 

Yes that works!! Thank you!

For future releases, this should be possible in one step = upgrade and configuration change will be merged into one.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...