Jump to content

ESMC shows wrong status


Recommended Posts

I have a Client task for full scan with shutdown scheduled weekly at Fridays on 22:00.

And in "Client Task Details - Executions" on Monday I see for some computers Last Status as Running, but those computers are switched off since Friday night.

When I switch them on, after some time the Last Status changes to Finished with Time from Friday night when the task actually have been finished.

It seems that sometimes the computer is switched off before it reports the status to the server.

Is it possible to change this behavior?

 

Link to post
Share on other sites

Remember that there is something called interval. This is the time when agent and console exchange theirs data. So if You launch task for example @ 22:00 and it will finish task at 22:19, agent wont pass current status to console.

  • You can play with connection interval's
  • make client task with scanning without shutdown + execute shutdown in other trigger

If You will choose to make 2 tasks, last one will have "running" status untill agent connect to console and upgrade their status

Link to post
Share on other sites
2 minutes ago, andy_s said:

To make 2 tasks I'll need the second one (with shutdown) be started after first (with scan) is finished. How could I make it?

Only option is to setup second task on specified date. If You use smart scanning, You are able to predict time You need to make a full scan.

To be honest, I run quite large scale environment and I run scan's when people work. So I get results right after task is completed.

Link to post
Share on other sites

It would be great in the future to make an option for shutdown delay (in minutes) in "Client task settings -> Shutdown after scan" to cover the connection interval.

Edited by andy_s
Link to post
Share on other sites

I think the best solution would be the option to launch task after a task is completed, or task sequencing.

This would allow for this current example, plus more complex tasking (install agent, reboot, install endpoint, reboot, full scan, run command (script) that sends email stating install tasks are completed -OR- runesetuninstaller.exe /nosafemode /force via cmd, reboot, runesetuninstaller.exe /nosafemode /force, reboot, runesetuninstaller.exe /nosafemode /force, reboot, install latest version of eset).

I had thought this was going to be included in v7 of the product-- it was not.

 

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...