Jump to content

Performing scheduled scan on PC in sleep mode


Recommended Posts

After doing some Googling trying to solve my problem I came across quite a few entries from this forum with the same problems I was facing so I'd thought I'd join and post my solution.

I use my PC as a media centre and the sleep timer is set to 30 mins.  This is a problem when you want to run a weekly scheduled scan.  There is a solution but it's a long winded one and it really shouldn't be like this.  ESET should have a feature that can wake up the PC to perform the scan and then keep it awake whilst the scan is performed but ESET has neither of these features.

My PC is now set to wake up from sleep mode then perform the scan and actually stay awake during the scan then revert back to the standard power plan afterwards therefore allowing it to go back to sleep after 30 mins of inactivity.

This is a brief description of how to do it.  I can go into more detail if required.

1. Use task scheduler to wake the PC from sleep mode.  This in itself is a pain because of Windows unattended wake up feature.  I got round it by running a key press script on wake up.

2. Use task scheduler to switch the power mode to a mode that is set to never sleep.  You have to do this otherwise the PC will go back to sleep after 30 mins or whatever your sleep timer is set to.  ESET isn't seen as an active process when performing a scan so Windows will just send the PC back to sleep on the sleep timer if you don't do this.  You can run a script or put the command directly into task scheduler.

3. Set ESET to perform the scan 5 minutes after task scheduler has woken up the PC.

4. Use task scheduler to set the PC back to the standard power plan with the sleep timer so the PC can go back to sleep.  I just set it to 8 hours after the start of the scan to give it plenty of time to perform the scan.  Again you can run a script or put the command directly into task scheduler.

Like I said it is a very long winded solution for such a simple task.  Maybe the developers can sort this out as it seems quite a common problem.

Edited by jakeycrx
Link to comment
Share on other sites

The problem here is not Eset's scan processing but the way Windows sleep processing works. Windows considers activity for sleep activation purpose to be desktop screen or keyboard activity.

You might want to check out this solution: http://www.zhornsoftware.co.uk/caffeine/ . Note that by default, it activates every 59 mins.. So you need to keep the Win sleep interval setting at 1 hour or more. I can't personally vouch for the app since I never used it.

Link to comment
Share on other sites

There are many things that can prevent Windows from entering sleep mode, not just mouse or keyboard input.  I have problems with Plex not allowing my PC to enter sleep mode.  The problem with ESET is that when it's performing a scan Windows doesn't see it as an active process so it will enter sleep mode during the scan.

If you don't want Windows to sleep just change the power settings to never allow sleep.  It's very simple.  You don't need an app.  I've already come up with a solution so why do I need to use an app?

There are a number of command prompts to study sleep behavior.  powercfg -requests is the most useful.  It shows which processes are running that will prevent Windows from entering sleep mode.  I'm currently streaming and running Filezilla.  Both of these processes will prevent my PC from entering sleep mode.  This is a screen shot of powercfg -requests:

 

Requests.JPG

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...