The detection is correct. The only way how to 100% resolve the issue is by upgrading UEFI to a version that doesn't contain Computrace, if available. Other than that, you have 2 options: 1, disable detection of potentially unsafe applications (not recommended, especially on servers and machines that might be a target of RDP attacks) 2, exclude the application from detection by its detection name as per https://support.eset.com/kb6519.