Jump to content

Apache HTTP Proxy settings for replication


sdnian
 Share

Recommended Posts

I'd like to settings ESMC agent v7 to connect ESMC Server through Apache HTTP proxy. But it's don't work.

For example, I've these three computers.

ESMC Server: 192.168.1.1

Apache HTTP Proxy: 192.168.1.2

ESMC Agent: 192.168.1.10

If let ESMC agent connect to EMSC server, port 2222. It works! 

But I setup to use proxy server, host: 192.168.1.2, port 3128 in ESMC agent. And I block source 192.168.1.10 in ESMC server. But it connect failed. 

If I change the httpd.conf. Remark the line 'deny from all' between <Proxy *> </Proxy>. It could connect again.

Next, I read the document - https://support.eset.com/kb6920/. So I've enable 'deny from all' back, but I add below contents:

<ProxyMatch ^192.168.1.1$>

Allow from all

</ProxyMatch>

It can't connect again. (I've restart Apache HTTP Proxy)

The error message:

ERROR: InitializeConnection: Initiating replication connection to 'host: "192.168.1.1" port: 2222' failed with: Request: Era.Common.Services.Replication.CheckReplicationConsistencyRequest on connection: host: "192.168.1.1" port: 2222 with proxy set as: Proxy: Connection: 192.1.1.2:3128, Credentials: Name: , Password: ******, Enabled:1, EnabledFallback:1, failed with error code: 14, error message: Connect Failed, and error details:
  • Replication details: [Task: CReplicationConsistencyTask, Scenario: Automatic replication (REGULAR), Connection: 192.1.1.1:2222, Connection established: false, Replication inconsistency detected: false, Server busy state detected: false, Realm change detected: false, Realm uuid: 5df4b312-4e4b-4aa4-b4ea-be3d56defcf0, Sent logs: 0, Cached static objects: 69, Cached static object groups: 10, Static objects to save: 0, Static objects to delete: 0, Modified static objects: 0]
  • All replication attempts: 91
 
What do I wrong?
 
Link to comment
Share on other sites

  • ESET Staff

@sdnian I have seen in the log, that you have used username & password in the credentials. As of now, it´s not possible to connect via proxy, which requires authentication.

Link to comment
Share on other sites

@MichalJ I've setup username/password for Apache HTTP Proxy, but still don't work. I have confirm the username/password are right.

The username is eset, password is 123

curl --proxy hxxp://192.168.1.2:3128/ -U eset:xxx https://edf.eset.com/edf
curl: (56) Received HTTP code 407 from proxy after CONNECT

The password of this command is wrong. So I get error code 407.

curl --proxy hxxp://192.168.1.2:3128/ -U eset:123 https://edf.eset.com/edf
<?xml version="1.0" encoding="UTF-8"?><ecp:message xmlns:ecp="hxxp://www.eset.com/2012/02/ecp"><ecp:response><code>20101003</code><message>Unsupported Content-type: unknown</message></ecp:response></ecp:message>

This command work well.

Now, ESMC Agent error message is..

ERROR: InitializeConnection: Initiating replication connection to 'host: "192.168.1.1" port: 2222' failed with: Request: Era.Common.Services.Replication.CheckReplicationConsistencyRequest on connection: host: "192.168.1.1" port: 2222 with proxy set as: Proxy: Connection: 192.168.1.2:3128, Credentials: Name: eset, Password: ******, Enabled:1, EnabledFallback:1, failed with error code: 14, error message: Connect Failed, and error details:
  • Replication details: [Task: CReplicationConsistencyTask, Scenario: Automatic replication (REGULAR), Connection: 10.11.3.247:2222, Connection established: false, Replication inconsistency detected: false, Server busy state detected: false, Realm change detected: false, Realm uuid: 5df4b312-4e4b-4aa4-b4ea-be3d56defcf0, Sent logs: 0, Cached static objects: 69, Cached static object groups: 10, Static objects to save: 0, Static objects to delete: 0, Modified static objects: 0]
  • All replication attempts: 215
Could you please tell me more detail information how to fix it? Thank you!
Edited by sdnian
Link to comment
Share on other sites

@Pinni3 Thank you for your reply. But at the first post, I used no credentials settings in the Apache HTTP Proxy. Okay, I removed the it, go back to the settings without authentication. But still don't work. Do you have other suggestions?

Link to comment
Share on other sites

  • ESET Staff

Just for verification, have you added also  AllowCONNECT 2222  to you proxy configuration?

I would recommend to enable full trace logging of HTTP proxy by adding/modifying following variable:

LogLevel debug

in httpd.conf. Once restart, proxy should write details of all connection attempts. This should revela whether proxy is rejecting connections, they are not processed at all or are rejected by ESMC Server.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...