Jump to content

Update to ERA Agent v7 not working.


Recommended Posts

ESET Remote Administrator is showing me an update to ERA Agent v7 and also an update for the rogue detection(only for the server ofc), but nothing happens when I run the tasks to update.

244210171_2018-08-2312_07_23-Window.thumb.png.59085b56b0254745a8139ec868330cf1.png

Link to post
Share on other sites

Go to installers and generate new installer + ini (if on linux then You need only installer in sh). And launch it on server. You cant upgrade agent on server via client task

Link to post
Share on other sites

Ok, thanks for the info. Only thing funny is, that it says to run the task for all and specifically says it will also update the server...but nonetheless the issue with the rogue detection persists. How come this doesn't update, too?Unbenannt.thumb.png.066294b61487550090e565494a286aaf.png

Edited by msc
Link to post
Share on other sites
  • ESET Staff

What you need to do, is to first upgrade the server to V7. Unless the server is upgraded to V7 (currently possible only manually) you won´t be able to choose valid server version (7.x) in the referenced server version. Once your server is upgraded to V7, the task will also upgrade other agents. 

Also please note, that ESMC V7 agent is NOT COMPATIBLE with the V6.x server. Once upgraded, it will not be able to connect, due to changed replication protocol. However, ERA Agent of versions 6.x will be able to communicate to ESMC server. Please upgrade the server first. 

Edited by MichalJ
Link to post
Share on other sites

Didnt noticed You are still on version 6. I upgraded my era to esmc but I upgrade esmc agent didnt worked for me via task. I installed it manually after re-generate inside console. 

Link to post
Share on other sites
1 hour ago, MichalJ said:

What you need to do, is to first upgrade the server to V7. Unless the server is upgraded to V7 (currently possible only manually) you won´t be able to choose valid server version (7.x) in the referenced server version. Once your server is upgraded to V7, the task will also upgrade other agents. 

Also please note, that ESMC V7 agent is NOT COMPATIBLE with the V6.x server. Once upgraded, it will not be able to connect, due to changed replication protocol. However, ERA Agent of versions 6.x will be able to communicate to ESMC server. Please upgrade the server first. 

May you have a link for me, I can't seem to find it on the website. Only ERA Server 6.x available for what I can see.

edit: nevermind, I found it. There are no knowledgebase Articles for v7 and on every site to download it still says v6.x so this was a bit confusing...

edit2: ok, there is an article but not easy to find when you're typing in remote administrator server all the time.

Edited by msc
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...