Jump to content

Eset HIPS disable but still keeps blocking


Recommended Posts

Hi,

I am new here and just installed ESET Smart Security 10.1.245.0 in a Windows 10 Pro Build 1709 partition. Now I have disabled HIPS but the HIPS pop-ups are still there. When I disabled it I restarted the PC as instructed. Can someone help me as I cannot work properly becaus even if I have disabled it it keeps on running and it's impossible to work!

 I am willing to learn Eset HIPS but as of the moment I need to work properly and the HIPS isn't helping. I have AppGuard installed so I can disable HIPS for the meantime. Please help me!

See images below. 

sjFBI7r.png

zttbPIc.png

EADPKza.png

 

Also in the firewall settings, can I use wildcards in Add Rules > Local > Applications, like, 

C:\Program Files (x86)\Wondershare\PDFelement 6 Pro\*

See image below.

8Z0VSSM.png

:(

Edited by BjorgBjorn
Link to comment
Share on other sites

  • Administrators

HIPS is as crucial protection module as real-time protection and should always remain enabled. Disabling HIPS also disables self-defense, Advanced Memory Scanner, Exploit Blocker and Ransomware Shield. That said, disabling HIPS substantially deteriorates protection, detection and cleaning capabilities of the installed ESET product.

As for HIPS rules, wildcards are not supported. Disabling HIPS (not recommended) requires a computer reboot for the change to take effect. Just to make sure that you perform a full computer restart, run "shutdown -r -t 0". With default HIPS configuration (ie. no custom rules created) you should get no prompts for action and yet it will provide protection against newly emerging threats.

Link to comment
Share on other sites

I would strongly heed Marcos' expert advice to leave HIPS protection enabled. Looking at your settings I believe the problem you're encountering may be due to your setting of the HIPS Filtering Mode to Interactive. I have HIPS Filtering Mode set to Automatic with all HIPS protection enabled and get no such popups. Give that a try and let us know if it works for you. :) Hopefully this simple change will enable you to get your work done!

Edited by Bill_k
Link to comment
Share on other sites

Also make sure you have the HIPS "Filtering mode" set to the default setting of "Automatic" or optionally, "Smart" mode. In either of these modes, you should receive HIPS alerts "once in a blue moon" at best.

I am also assuming that you haven't created any HIPS user rules?

Link to comment
Share on other sites

  • Administrators
6 hours ago, Azure Phoenix said:

I believe you meant firewall rules. HIPS supports wildcards, the firewall doesn't.

I indeed meant HIPS rules. Wildcards are only supported in registry paths AFAIK.

Link to comment
Share on other sites

Thanks so much all for your reply and explanation. I do intend to use HIPS but just was overwhelmed at the many pop-ups it threw. I was just starting and I could not even do anything..Is there a way that I can place it in learning mode -- just the HIPS. 

Okay on the wildcard question. I do meant the "firewall" but thanks guys for pointing out also wildcards in HIPS. I did not know that. Great tip!

Thanks again. It's been a while since I used Eset. HIPS was new then I remember. 
 

Link to comment
Share on other sites

11 hours ago, Marcos said:

you perform a full computer restart,

that's right.its a bug but you never fixed it : (

26 minutes ago, BjorgBjorn said:

I was just starting and I could not even do anything..Is there a way that I can place it in learning mode -- just the HIPS. 

Yes, you can but its a bit tricky.

if hips showing you 1000 alerts and you wanna change the hips mode but  can't then follow these steps:

1-enable gamer mode so Eset won't show any alert

2-go to hips settings and set it to smart mode!

3-GL

 

Link to comment
Share on other sites

  • Administrators
Quote

that's right.its a bug but you never fixed it : (

I'm sorry but I have absolutely no clue as to what we were supposed to fix.

Link to comment
Share on other sites

When you disable the HIPS you have to restart the windows to see the effects(it decrease the usability) otherwise it keeps showing alerts.

I use gamer mode to fix this issue.

Edited by persian-boy
Link to comment
Share on other sites

  • Administrators
5 hours ago, persian-boy said:

When you disable the HIPS you have to restart the windows to see the effects(it decrease the usability) otherwise it keeps showing alerts.

This is not a bug but a security feature which is there intentionally. We won't allow disabling HIPS without the need to restart the computer.

Link to comment
Share on other sites

Thanks for all your explanation. I updated to EIS yesterday and it went fine. I also see that you can set it at learning mode so that is what I did. About the gamer mode. I may tinker with it when I start playing but my games is at a different partition with a different security setup. 

Link to comment
Share on other sites

  • 1 month later...

Windows 10 New Install and HIPS will not enable Have tried to disable, enable. Have downloaded latest updates, for both

ESET Smart Security Premium  and Windows, still no luck. Please advise what steps to take to resolve this issue. On the verge of uninstalling and using a friendlier product. Shouldn't be this hard!

Link to comment
Share on other sites

  • Most Valued Members
On 8/21/2018 at 10:01 AM, BjorgBjorn said:

Thanks for all your explanation. I updated to EIS yesterday and it went fine. I also see that you can set it at learning mode so that is what I did. About the gamer mode. I may tinker with it when I start playing but my games is at a different partition with a different security setup. 

It shouldn't matter where your games are installed if in different partition or same partition as ESET , when you go into a full-screen mode in-game then the gamer mode should turn on automatically if I remember correctly.

Link to comment
Share on other sites

  • Administrators
2 hours ago, internetangels said:

Windows 10 New Install and HIPS will not enable Have tried to disable, enable. Have downloaded latest updates, for both

Are you getting an error in the main gui that HIPS is non-functional ? Do you have another security sofware installed together with ESET?
Please gather logs with ELC and provide the generated archive for perusal.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...