Jump to content
reisley

AiO Installer download fails, "internal server error"

Recommended Posts

ERA Server 6.5.522.0

ERA Web Console 6.5.388.0

ESET Endpoint Security 6.6.2086.1

ESET File Security for Windows Server 6.5.12017.0

 

Any attempt to download an AiO installer (32-bit or 64-bit) fails, with vague "Internal server error" message (see attached example), but downloading the MSI installers directly from ESET web site (on same machine as ERA Server) works without fail.  Disabling firewall and other applications has no effect.

Any attempt to update ESET application on client machine (desktop or server) from the ERA server fails, but doing so directly on the client machine (using the downloaded MSI) works.

Any other ESET client task seems to work properly: clients receive and respond to Server commands to reboot, update Windows, etc

The trace.log created during one attempt to download an AiO (see attached) does not seem to provide any clarity.  I did not see any errors or failures. 

Please help.

 

AiO error.pdf

trace.log

Share this post


Link to post
Share on other sites

According to provided logs, problem is network related - during download, it is somehow interrupted before it could be finished. Any chance this server is physically places somewhere not in US or EU? For example we have recently received reports from Japan, where it seems network connection to ESET repository servers is not capable enough. Any chance you are using HTTP proxy which could also result in this problem?

Share this post


Link to post
Share on other sites

I'm having this exact same issue. I noticed we had a bunch of machines have their signature downloads interrupted last week, but that seems to have cleared. However, when trying to download the AIO installer, I'm running into the exact same problem. I've confirmed that nothing on our side is blocking communication. I get the Internal Server Error after five minutes. I tried combing through the trace log, but with debug verbosity it's incredibly hard to find. I did find one stating error during file get request standard exception, but I eventually stopped combing through everything. I'm located in the US.

Share this post


Link to post
Share on other sites
8 hours ago, MartinK said:

According to provided logs, problem is network related - during download, it is somehow interrupted before it could be finished. Any chance this server is physically places somewhere not in US or EU? For example we have recently received reports from Japan, where it seems network connection to ESET repository servers is not capable enough. Any chance you are using HTTP proxy which could also result in this problem?

MartinK,

ERA Server is located in Japan.  It makes sense that might be the problem, as Canon IT handles ESET in Japan and they do a very poor job.  I cannot even download MSIs directly from their local ESET site because they require email authorization with a sales rep for each download.  I use the "International (English)" site for all direct MSI downloads.  

Is there a way to force the ERA Server to use a non-local ESET source?  It would be an excellent test anyway, even if it is not a sustainable solution.

Note:  having HTTP proxy enabled or disabled makes no difference in AiO download success.  It always fails either way.

Please let me know how to further test.  Thank you.

     

Share this post


Link to post
Share on other sites

Fixed.  Suddenly, the ESET servers in Japan are now very responsive.  I assume you took the issue up with Canon IT.  Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×