Jump to content

ERA Server broken in VA after updating to mysql-community v5.6.41


Recommended Posts

Today i've updated a couple of ERA VAs with "yum update". It brings a new mysql-community version (5.6.41).

After that ERAServer stopped working.

It seems like the odbc-driver is unable to connect to the database.

Last  lines of ERA trace.log

2018-07-30 10:38:08 Warning: CDatabaseModule [Thread 7f638403b700]: Dependability checks of underlaying layer failed with: The underlying unixodbc implementation has not support for multithreading.
2018-07-30 10:38:08 Information: CDatabaseModule [Thread 7f638403b700]: Startup connection pool created ...
2018-07-30 10:38:08 Information: CDatabaseModule [Thread 7f638403b700]: Builder rebuilds successfully ...
2018-07-30 10:38:08 Information: CDatabaseModule [Thread 7f638403b700]: Connection pool recreated ...
2018-07-30 10:38:08 Information: CDatabaseModule [Thread 7f638403b700]: CDBSetupperBase::PerformUpgradeIfNecessary: Checking if ETL DB is required
2018-07-30 10:38:08 Information: CDatabaseModule [Thread 7f638403b700]: CDBSetupperBase::PerformUpgradeIfNecessary: Clean installation
2018-07-30 10:38:08 Information: Kernel [Thread 7f638403b700]: Unloading module: CUpdatesModule
2018-07-30 10:38:08 Information: Kernel [Thread 7f638403b700]: Unloading module: CTranslatorModule
2018-07-30 10:38:08 Error: Service [Thread 7f638403b700]: [MySQL][ODBC 8.0(w) Driver][mysqld-5.6.41]Duplicate entry 'db_starschema' for key 'PRIMARY'

 

Who can confirm this issue ?

Any hints of fixing that ?

 

Link to post
Share on other sites

Hi Marcos,

this was the  issue a couple of months ago. So this is a different thing.

Installed Packages on non working ERA
mysql-community-client.x86_64                                            5.6.41-2.el6                                      @mysql56-community
mysql-community-common.x86_64                                      5.6.41-2.el6                                      @mysql56-community
mysql-community-libs.x86_64                                               5.6.41-2.el6                                      @mysql56-community
mysql-community-libs-compat.x86_64                                 5.6.41-2.el6                                      @mysql56-community
mysql-community-release.noarch                                            el6-5                                             @/mysql-community-release-el6-5.noarch
mysql-community-server.x86_64                                            5.6.41-2.el6                                      @mysql56-community

mysql-connector-odbc.x86_64                                                8.0.12-1.el6                                             @mysql-connectors-community
unixODBC.x86_64                                                                    2.2.14-14.el6                                            @base

 

Startupconfiguration:

DatabaseType=MySqlOdbc
DatabaseConnectionString=Driver=MySQL ODBC 8.0 Unicode Driver;Server=127.0.0.1;Port=3306;User=era;....... (altered with the the sed line from kb6760)

 

 

 

 

 

Link to post
Share on other sites
  • ESET Moderators

Hello Lemmi,

We have reported this to our developers. In the meantime, we have learned that downgrading the ODBC driver to 8.0.11 or 5.3 restores the functionality.

We will update this thread when more information is available.

T.

Link to post
Share on other sites
# yum downgrade mysql-connector-odbc
Resolving Dependencies
--> Running transaction check
---> Package mysql-connector-odbc.x86_64 0:8.0.11-1.el7 will be a downgrade
---> Package mysql-connector-odbc.x86_64 0:8.0.12-1.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================
 Package                                        Arch                             Version                                   Repository                                            Size
===============================================================================================================================================
Downgrading:
 mysql-connector-odbc                           x86_64                           8.0.11-1.el7                              mysql-connectors-community                           2.8 M

Transaction Summary
===============================================================================================================================================
Downgrade  1 Package

Total download size: 2.8 M
Is this ok [y/d/N]: y
Downloading packages:
mysql-connector-odbc-8.0.11-1.el7.x86_64.rpm                                                                                                                   | 2.8 MB  00:00:00     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : mysql-connector-odbc-8.0.11-1.el7.x86_64                                                                                                                           1/2 
  Cleanup    : mysql-connector-odbc-8.0.12-1.el7.x86_64                                                                                                                           2/2 
  Verifying  : mysql-connector-odbc-8.0.11-1.el7.x86_64                                                                                                                           1/2 
  Verifying  : mysql-connector-odbc-8.0.12-1.el7.x86_64                                                                                                                           2/2 

Removed:
  mysql-connector-odbc.x86_64 0:8.0.12-1.el7                                                                                                                                          

Installed:
  mysql-connector-odbc.x86_64 0:8.0.11-1.el7                                                                                                                                          

Complete!

# yum list mysql-connector-odbc
Installed Packages
mysql-connector-odbc.x86_64                                                          8.0.11-1.el7                                                          @mysql-connectors-community
Available Packages
mysql-connector-odbc.x86_64                                                          8.0.12-1.el7                                                          mysql-connectors-community 

# reboot

Confirming this procedure did resolve the issue after having upgraded ERA appliance's mysql-connector-odbc via yum update to 8.0.12-1.

Edited by beaconfed
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...