Jump to content

SSL Protocol Filtering Quit Working With The Bat! 6.1.2 And Newer


Recommended Posts

  • ESET Insiders

Hello,

 

I have used The Bat! for e-mail along with ESS for years now and SSL protocol filtering has always worked very well with no issues. Upon updating The Bat! from version 6.0.12 to 6.1.2, ESS is no longer scanning the e-mails. No settings have changed with ESS. I tried a repair install of ESS but problem was still present. I then did a complete uninstall of ESS (including running the uninstall tool in safe mode), did a fresh install and complete new set-up of advanced settings, but the issue is still there. This morning The Bat! updated to version 6.1.4 but still no scanning of e-mails. I have tried using both The Bat!'s own internal certificate store and Window's certificate store settings within The Bat!, but still no scanning of e-mails.

 

I do not know if maybe a module has changed within ESS to cause this or not, I do use the pre-release versions of the modules. I do know that The Bat! with version 6.1.2 changelog is:

 

New features

  • TLS 1.1
  • SSL 3.0
  • Import of Exchange contacts from MS Outlook
  • Added support for hardware CRAM-MD5 (token) authentication in IMAP

Improvements

  • Split messages aren't automatically combined in IMAP folders
  • Faster message retrieval over POP3 with large volumes of messages kept on the server
  • A high-resolution version of the main program icon has been added

Fixes

  • Additional images could not be attached after an image had been removed from the HTML-message body
  • Switching to HTML tab did hide tab pane when message is viewed in separate window
  • Improper displaying of addresses with paired double quotes
  • Setting message tags with the "Message|Tags|More tags" command was broken
  • Wrong editor format indication when the %SetEditor macro was used
  • The SMTP option "Do not store password, prompt on retrieval" now functions properly
  • Import from Google Contacts was partial in some cases
  • Import from Microsoft Outlook Express address book didn't work properly
  • It wasn't possible to make program associations in Windows XP
  • Smileys and Rogues were inactive
  • Bugs in the dial-up access functionality have been fixed
  • (#0000243) "Invalid Pointer Operation" on every other call of Print
  • Time in Cron format was incorrectly handled in the Scheduler
  • Export of addressbook as text or csv generates UTF-8 without BOM for MS Excel, it leads to wrong non-latin characters
  • Cannot upgrade from 5.8.8 to 6.x using eToken OTFE
  • Fixed exception when drag-n-drop ABD file from Win Explorer to white region of address books list
  • TLS connections with some servers didn't work.

I figure with these changes in The Bat! something has caused the scanning to break, but should not ESS still be scanning POP3S on port 995 even if The Bat! made changes? Any help and ideas on how to get POP3S scanning on port 995 for e-mail (SSL protocol filtering) working again would be greatly appreciated. Thanks.....

Link to comment
Share on other sites

  • Administrators

I've installed the latest version of TheBat! and in spite of importing the ESET root certificate to the Trusted root CA list, I'm getting an error  "TLS handshake failure. Unsupported certificate". It seems that TheBat! doesn't accept self-signed root certificates and refuses connection.

Link to comment
Share on other sites

  • ESET Insiders

Thanks for your response Marcos.

 

I assume your are using the default setting of The Bat!'s own internal certificate store and imported the ESET certificate there. I have done that and do not get that error. I have also tried changing that default setting within The Bat! to use Windows certificate store as ESET automatically imports its certificate there. I do not get that error that way either. I receive my emails both ways with no errors but ESS is not scanning them.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...