Cyril Vialle

Problems for deploy Remote Agent Windows 10 x64

Recommended Posts

Hi!

I have a problem installing the agent from the console to a Windows 10 x64 computer:

 2018-06-11 10:36:38 Error: CRemoteInstallModule [Thread 7f6d847c0700]: Executing remote deployment of agent 853d26f1-993b-4a20-ba20-919e1dd4b284 on 'poste_si14.protection24.lan'
Windows network remote deployment failed.
*** Error details: UnixWindowsNetworkRemoteInstall: remote deployment to 'poste_si14.protection24.lan' terminated with 32

All is ok, the Windows fire is off and the file sharing works.

Where can this failure come from?

Thank you

Share this post


Link to post
Share on other sites

Do you use ERA Server virtual appliance or you installed ERAS on an existing Linux system ?

Is the following command executed without an error?

smbclient '\\poste_si14.protection24.lan\ADMIN$' -U 'Administrator'

Share this post


Link to post
Share on other sites

I use the virtual appliance.
The command tells me that 'smbclient' is not installed.

-bash: smbclient: command not found

I have no problem for deployment on Windows 7 x86

Share this post


Link to post
Share on other sites

I think I found the problem.
The command to mount the ADMIN$ shared folder is not the correct one for Windows 10. It must be in version 3.0

Command in failure:

# mount -t cifs -o username=XXX,password=XXX,domain=XXX //poste_xxx.protection24.lan/ADMIN$ /tmp/testdir/
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Successful Command:

# mount -t cifs -o username=XXX,password=XXX,domain=XXX,vers=3.0 //poste_xxx.protection24.lan/ADMIN$ /tmp/testdir/

Is there a setting in Remote Administrator to change the version following the computers?

Share this post


Link to post
Share on other sites

I tested by modifying the UnixWindowsNetworkRemoteInstall.sh file on line 134 by adding "vers=3.0" the deployment works.

LANG= mount -t cifs -o "${mount_domain_option}username=$ERA_RD_WN_USERNAME,vers=3.0" "$remote_cifs_share" "$local_cifs_mount"

This parameter should be dynamic

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.