Jump to content

VerifyFileContentSignature: Failed to validate PGP signature: Error while parsing


NilsJ
 Share

Recommended Posts

Hi,

 

when I try to deploy an Agent via the ERA Webinterface I always get this message: VerifyFileContentSignature: Failed to validate PGP signature: Error while parsing

It stoppend working just now. Last time I used it, it worked perfectly. 

Is that a problem that goes away after a bit?

 

best regards

Nils

Link to comment
Share on other sites

As suggested by technical support and assuming you're using the Linux version, try deleting the contents of the cache folder (/var/cache/httpd/proxy) and restarting the ERAServer service. I did this and it worked for me.

Link to comment
Share on other sites

  • ESET Staff

Could someone please provide Wireshark capture with HTTP communication (in PM for privacy)? It is possible that invalid data were cached, and we would like to confirm that.

Link to comment
Share on other sites

Hi.

I have contacted Eset support and they said there is problem with Apache HTTP proxy (only Windows?). Workaround is disable http proxy usage everywhere (server, agent and eset products). Strange.

Link to comment
Share on other sites

  • ESET Staff

@VIP Problem is not with Apache in particular or with the proxy. Problem is with invalid data being cached. They have set expiration for 7 days, so the solution would be to clear the proxy cache, not to disable caching / proxy at all. MartinK requested the data, to verify this suspicion, that seems to be the most likely reason for the problems. 

Link to comment
Share on other sites

Yes you are right. Stopping HTTP proxy service, deleting cache and start HTTP Proxy resolves the problem..

Link to comment
Share on other sites

Hi, 

I'am currently  using the virtual appliance ( v 6.5.417.0) and I also have an empty repository list since Wednesday. 

As explained in this topic,   I cleaned the Apache HTTP proxy then rebooted eraserver.service but it's still empty. 

Before cleaning i stopped httpd service.  should I stop httpd proxy service only? 

Moreover  Davindenco said to clear /var/cache/httpd/proxy but my  its an empty directory, only cached data I checked with htcacheclean -p /var/cache -A are located in /var/cache/httpd/mod_cache_disk 

Any help is welcomed 

Best Regards

Olivier.

 

Link to comment
Share on other sites

  • ESET Staff
3 hours ago, ODLR said:

Hi, 

I'am currently  using the virtual appliance ( v 6.5.417.0) and I also have an empty repository list since Wednesday. 

As explained in this topic,   I cleaned the Apache HTTP proxy then rebooted eraserver.service but it's still empty. 

Before cleaning i stopped httpd service.  should I stop httpd proxy service only? 

Moreover  Davindenco said to clear /var/cache/httpd/proxy but my  its an empty directory, only cached data I checked with htcacheclean -p /var/cache -A are located in /var/cache/httpd/mod_cache_disk 

Any help is welcomed 

Best Regards

Olivier.

 

Any chance you are using non-default configuration for repository url (ERA server settings)? Or maybe there is another HTTP proxy between ERA and internet (ESET infrastructure)? I would also check ERA Server's trace log for Errors related to repository synchronization, which is performed every 60 minutes. Is it for example possible to disable HTTP proxy and enable direct access to internet for ERA server (server settings)? If it will help, it is probable something went wrong with HTTP proxy - or is it working for other ESET services, like modules update, i.e. is it caching newly downloaded files once cache was purged?

Link to comment
Share on other sites

Hi, 

My list is not empty anymore. I do not know what happened during the week-end. 

I will Invistigate later to understand.

thanks for your fast answer

 

Best Regards

Link to comment
Share on other sites

4 hours ago, Jocades said:

Same issue here. Windows ERA, Windows clients.

I have to add that, I've stopped the proxy service, and...

C:\Program Files\Apache HTTP Proxy\cache

That path is completely empty (even checked show hidden folders/files). Restarted, the service, relaunched the tasks, and failed again.

Link to comment
Share on other sites

37 minutes ago, VlP said:

Wrong path, correct is C:\ProgramData\Apache HTTP Proxy\cache

Oh! It worked like a charm, thank you!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...